世纪星 FAQ

FAQ目录
  • 软件安装
  • 加密锁
  • 工程项目管理
  • 开发系统
  • 变量字典
  • 画面编辑
  • 动画连接
  • 命令语言
  • 函数
  • 报警窗口
  • 历史曲线
  • 配方管理
  • 控件管理
  • 联网运行
  • WEB发布
  • 报表打印
  • ODBC功能
  • 设备驱动
  • 安全与权限
  • 运行系统


软件安装

  1. 世纪星能否在WIN7、WIN8系统上使用？

  2. 安装世纪星时，出现“移动数据错误”或其他安装异常现象，如何解决？

  3. 安装世纪星时，显示安装100%后，不正常退出，怎么办？

  4. 可以不卸载，直接用新版本覆盖安装旧版本吗？

  5. 安装世纪星时，点击“安装世纪星”，不出现安装界面，如何解决？

  6. 不安装世纪星，直接从其他电脑复制世纪星，可以吗？

1、世纪星能否在WIN7、WIN8系统上使用？

可以，世纪星支持Windows XP、WIN7、WIN8操作系统，支持32位、64位WIN7、WIN8操作系统。

安装要求：电脑的操作系统必须是带系列号安装的，因为大部分Goust系统裁剪不完整，很多功能不能使用。

返回

2、安装世纪星时，出现“移动数据错误”或其他安装异常现象，如何解决？

(1) 可能是目标目录中的某些文件已被系统使用，建议重启计算机把已安装的目录删除再安装。

(2) 关掉防火墙或者杀毒软件，然后重新安装软件。

(3) 更换世纪星安装光盘，或从世纪星官网下载最新版的软件安装包。

返回

3、安装世纪星时，显示安装100%后，不正常退出，怎么办？

安装世纪星时，显示安装100%，说明软件文件已经安装完毕，由于各个系统版本不一样，注册控件、驱动程序及创建快捷方式等部分没有正常执行，这时，可以手动完成安装：

(1) 在世纪星系统目录(缺省:C:\CenturyStar)中运行注册工具: RegAll.exe，注册系统的控件和驱动程序。

(2) 创建开发系统快捷方式：在世纪星系统目录(缺省:C:\CenturyStar)中，用鼠标右键点击 CSMaker.exe，弹出菜单中选择“发送到”-->“桌面屏幕快捷方式”，修改快捷方式名称为：世纪星9.1开发系统。

(3) 创建开发系统快捷方式：在世纪星系统目录(缺省: C:\CenturyStar)中，用鼠标右键点击 CSViewer.exe，弹出菜单中选择“发送到”-->“桌面屏幕快捷方式”，修改快捷方式名称为：世纪星9.1运行系统。

返回

4、可以不卸载，直接用新版本覆盖安装旧版本吗？

建议卸载老版本软件，因为，我们要确保老版本的程序没有在电脑内存中驻留，如果有程序驻留，这些程序及其相关支持程序将无法覆盖，就会造成系统无法正常运行。

卸载老版本软件后，建议删除世纪星的系统目录(缺省: C:\CenturyStar)，再安装新版本软件即可。

返回

5、安装世纪星时，点击“安装世纪星”，不出现安装界面，如何解决？

安装界面中，点击“安装世纪星”，安装软件是调用安装盘中目录CenturyStar中的 Setup.exe 文件，如果不出现安装界面时，用以下三种方法：

(1) 查看任务管理器中，Setup.exe 是否运行，如果运行，可以等待一会，安装界面就会显示，如果长时间没有显示安装界面，可以重新启动电脑，再安装世纪星。

(2) 操作系统有权限设置，在安装盘中目录CenturyStar中，用鼠标右键点击Setup.exe 文件，弹出菜单中选择“以管理员身份运行”。

(3) 打开电脑的“任务管理器”，点击“进程”选项，尝试结束某些进程，查看安装界面是否弹出。此类进程一般为：QQ保护进程、支付宝相关的保护进程等。

(4) 在其他电脑上安装世纪星，将世纪星系统目录复制到这台电脑，手动注册控件、驱动程序及创建快捷方式。

返回

6、不安装世纪星，直接从其他电脑复制世纪星，可以吗？

可以。世纪星安装程序主要功能：复制世纪星组态软件、注册控件、驱动程序及创建快捷方式。

直接从其他电脑复制世纪星组态软件后，需要手动完成以下工作：

(1) 在世纪星系统目录(缺省: C:\CenturyStar)中运行注册工具: RegAll.exe，注册系统的控件和驱动程序。

(2) 创建开发系统快捷方式：在世纪星系统目录(缺省: C:\CenturyStar)中，用鼠标右键点击 CSMaker.exe，弹出菜单中选择“发送到”-->“桌面屏幕快捷方式”，修改快捷方式名称为：世纪星9.1开发系统。

(3) 创建开发系统快捷方式：在世纪星系统目录(缺省: C:\CenturyStar)中，用鼠标右键点击 CSViewer.exe，弹出菜单中选择“发送到”-->“桌面屏幕快捷方式”，修改快捷方式名称为：世纪星9.1运行系统。

返回


加密锁

  1. 加密锁有什么用途？

  2. 加密锁从硬件接口上分哪几种？

  3. 世纪星有几种加密锁？有什么区别？

  4. 如果加密锁不能正常使用，或者系统提示找不到加密锁，如何处理？

  5. 计算机并口上连接了打印机，应如何连接并口加密锁？

  6. 在一个并口上接软驱和加密锁，为什么找不到加密锁？

  7. 使用加密狗，一旦使用打印机则找不到加密狗？

  8. 计算机上没有并口，能否采用USB转并口的线然后连接并口加密锁使用吗？

  9. 我的电脑有一XP系统和一WIN7系统，为什么在XP系统下能找到加密硬件，而WIN7却不行？

  10. 多个USB加密锁能否插在一起使用？

  11. 多个并口加密锁能否插在一起使用？

  12. 用户如何能够获取世纪星加密锁的序列号？

  13. OEM版本的加密锁能否直接在世纪星上使用？

  14. 在开机时自动启动世纪星时，为什么找不到加密锁？

  15. 如何查看加密锁类型？

1、加密锁有什么用途？

加密锁是世纪星正版的标志。加密锁是一个硬件加密设备，连接到电脑的USB接口或并口上。俗称：加密狗。

加密锁分开发版加密锁和运行版加密锁：开发锁用于开发用户工程项目，每个开发锁同时只能有一台电脑使用，一个工程师只需要购买一个开发锁就可以长期使用；运行锁是用户工程项目用到现场时使用的加密锁，现场每台电脑都需要一个运行锁。

用系统安装盘安装世纪星后，执行开发系统和运行系统时，如果没有加密锁，系统会提示“系统未找到加密硬件”信息，点击“忽略”，世纪星为演示版，演示版软件支持256点开发，运行时间是2个小时，即每次启动运行系统时，系统在2个小时后会提示退出。

安装加密锁后，世纪星即成为正版软件。

返回

2、加密锁从硬件接口上分哪几种？

加密锁从硬件接口上分两种：并口锁和USB锁。

(1) 并口锁：使用计算机的并口，并口打印机可以接到加密锁的后面使用；

(2) USB锁：使用计算机的USB口，不能够作为U盘使用。

返回

3、世纪星有几种加密锁？有什么区别？

世纪星的加密锁有三种：开发锁、运行锁和WEB锁。开发锁用于工程人员开发、修改、调试用户工程项目；运行锁用于现场运行用户工程项目，不能打开、修改用户工程项目。区别如下：

(1) 开发锁：分512点和无限点开发，均运行2个小时，WEB 1个用户。【256点及小于256点时不需要开发锁】

(2) 运行锁：分64点、128点、256点、512点、1024点和无限点运行。

(3) WEB锁：分2用户、5用户、10用户、20用户、50用户和无限用户。

返回

4、如果加密锁不能正常使用，或者系统提示找不到加密锁，如何处理？

出现这种情况的原因有多种，请对照如下提示逐一检查：

(1) 确认插口或者插槽是完好的，可用其他USB口测试。

(2) 重新安装加密锁驱动，注意安装时不要插加密锁。加密锁驱动目录：在系统目录中有个Sentinel目录(缺省：C:\CenturyStar\Sentinel)。

(3) 安装加密锁驱动后仍然无法识别加密锁，可能是电脑中有加密锁的其他版本驱动程序，需要先清除这些驱动程序，清除方法：在系统目录中有个Sentinel目录(缺省：C:\CenturyStar\Sentinel)，运行SSDCleanup 清除已经安装的加密锁驱动程序，再安装加密锁驱动程序。

(4) 加密锁损坏(可以在其它电脑上测试)，与厂家联系更换。

返回

5、计算机并口上连接了打印机，应如何连接并口加密锁？

可以将并口加密锁直接连接在计算机的并口上，然后将打印机插在加密锁上即可。

返回

6、在一个并口上接软驱和加密锁，为什么找不到加密锁？

在笔记本上，如果活动软驱使用机器的并口，则不能插在加密锁上。这点与打印机可以插在加密锁上不同。用户只能避开同时的情况。

返回

7、使用加密狗，一旦使用打印机则找不到加密狗？

(1) 将并口设为ECP方式（在BIOS中设置）；

(2) 安装驱动程序；

(3) 并口的驱动能力可能有问题，建议增加一并口扩展卡，连接打印机。

返回

8、计算机上没有并口，能否采用USB转并口的线然后连接并口加密锁使用吗？

对于没有并口的计算机，请用户购买USB口的加密锁，不建议使用并口扩展卡。

返回

9、我的电脑有一XP系统和一WIN7系统，为什么在XP系统下能找到加密硬件，而WIN7却不行？

WIN7和WIN8系统有严格的用户管理权限，需要用管理员身份运行加密锁安装程序。

返回

10、多个USB加密锁能否插在一起使用？

开发锁和运行锁不能同时使用。但是，可以在Windows 的设备管理器中，找到对应的加密锁，通过“允许”、“禁用”功能选择使用那个加密锁。

返回

11、多个并口加密锁能否插在一起使用？

不可以，同一个并口上不允许同时插上开发锁和运行锁。

返回

12、用户如何能够获取世纪星加密锁的序列号？

每一个加密锁都一个固定的序列号，可以通过加密狗相关函数读取。利用本功能可以对用户工程项目使用唯一的加密锁。

返回

13、OEM版本的加密锁能否直接在世纪星上使用？

不可以，其他厂家定制的OEM版本的加密锁只能使用在OEM版本的软件上，在世纪星上不能使用。同理，世纪星的加密锁也不能在OEM版本软件上使用。

返回

14、在开机时自动启动世纪星时，为什么找不到加密锁？

这是因为加密锁驱动程序加载时，世纪星已经启动运行，因此，找不到加密锁。可以采用以下方法优先加载加密锁驱动程序：

(1) 在“开始 → 运行(R)…”中执行“Regedit”注册表编辑器，找到 “HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Sentinel”项，用鼠标左键双击编辑其中的数据项“Start”，修改其数据数值为 1。

说明：Start =1：系统在加载其他驱动程序前，先加载加密狗驱动程序。

Start =2：系统在加载其他驱动程序后，再加载加密狗驱动程序。

(2) 关闭注册表编辑器。

(3) 重新启动即可。

返回

15、如何查看加密锁类型？

在开发系统的菜单：“帮助”--“关于开发系统......”中，可以查看软件的版本、加密锁类型等信息。


工程项目管理

  1. “工程项目管理器”的用途是什么？

  2. 如何找到“工程项目管理器”？

  3. 如何对我的工程项目进行保护、加密或不让用户重新组态呢？

  4. 工程密码丢失了，是否可以解密呢？

  5. 工程加密后，用户想清除加密的信息，如何处理呢？

  6. 我开发了一个工程，希望加密以防止其他人员打开我的工程看我的工程设计，如何操作？

  7. 工程加密会影响世纪星的运行吗？

  8. 世纪星中实现工程加密时，能否对单个画面进行加密？

  9. 如何打开从网站上下载的工程实例？

  10. 能否把世纪星的工程文件变小？

  11. 光盘上的示例工程无法打开？

  12. 进行工程备份的恢复时显示恢复失败？

  13. 如何设置工程分辨率，以便与电脑匹配？

  14. 请简单介绍一下实际工程？

  15. 一套软件能运行多个工程吗？

  16. 不同分辨率的画面文件如何转换，如640*480的画面怎样转化成800*600？

  17. 开发新的工程项目时，如何借助其它工程项目中的内容？

  18. 老版本用户工程项目升级时，需要注意哪些方面？

1、“工程项目管理器”的用途是什么？

工程项目管理器用于管理电脑上所有的用户工程项目，可以打开、连接、修改、删除用户工程项目。示例：在电脑上开发了三个用户工程项目，每个切换用户工程项目时，就可以通过“工程项目管理器”实现。

在“工程项目管理器”中，选择一个工程项目，还可以实现：用户工程项目备份/恢复、用户工程项目保护(密码加密)、屏幕分辨率转换、变量字典中变量的导入/导出等功能。

返回

2、如何找到“工程项目管理器”？

在开发系统中，主窗口提供两个菜单：一是画面打开前的菜单，或者没有画面打开时的菜单，菜单项是与系统功能相关的菜单；二是画面打开后的菜单，或者有画面打开时的菜单，菜单项是与画面编辑功能相关的菜单。

“工程项目管理器”是在画面打开前，或者是关闭所有打开的画面后，在“文件”菜单中有“工程项目管理”菜单项。

返回

3、如何对我的工程项目进行保护、加密或不让用户重新组态呢？

在工程项目管理对话框中，先选中要加密的工程项目，单击“保护”功能按钮，输入密码即可对工程项目加密。

以后每次打开工程项目时，必须输入密码，才可以重新组态。

返回

4、工程密码丢失了，是否可以解密呢？

世纪星提供很安全的加密手段，也就是加密过程比较复杂。我们一般不提供解密服务，如果要解密，则：提供工程项目所有权的证明文件、承担解密风险的承诺书、比较高的解密服务费用。因此，不要忘记工程项目的密码。

返回

5、工程加密后，用户想清除加密的信息，如何处理呢？

在“工程项目管理器”中，选中所要解密的工程，点击菜单中“保护”，输入原工程保护密码，“新密码”对话框中不输入任何信息直接点击“确定”，即可清除加密信息。

返回

6、我开发了一个工程，希望加密以防止其他人员打开我的工程看我的工程设计，如何操作？

(1) 在“工程项目管理器”中提供工程项目保护功能，通过密码实现用户工程项目的保护。

(2) 画面文件: *.WIN 用于开发系统画面编辑文件，如果删除 *.WIN 画面文件，有开发系统也无法查看画面。注意：删除前要备份用户工程项目，否则，自己也无法打开画面了。

返回

7、工程加密会影响世纪星的运行吗？

工程加密设置只是限制用户打开工程，不会影响工程的正常运行。也就是说用户在运行此工程时，软件不会检测工程密码状态。如果用户希望在运行时也保护，可以采用通过函数，读取并识别加密锁的序列号来实现。

返回

8、世纪星中实现工程加密时，能否对单个画面进行加密？

加密是针对所有的画面进行的操作，不能对单个画面进行加密。

返回

9、如何打开从网站上下载的工程实例？

先将下载的工程实例进行解压，用“工程项目管理器”连接并打开工程实例。

返回

10、能否把世纪星的工程文件变小？

世纪星的工程文件中，“.WVW”是系统编译生成的文件，保存文件时可以删除，它们在下次保存画面时将自动生成。“*.LGH”和“*.IDX”是历史数据文件，“ALM*.DB1”是历史报警数据文件，可以有选择删除。

返回

11、光盘上的示例工程无法打开？

光盘上的所有文件是只读属性文件，可以将工程项目拷贝到硬盘上，将所有文件的只读属性去掉即可。

返回

12、进行工程备份的恢复时显示恢复失败？

所恢复的工程不是当前工程的备份，在恢复对话框的提示选项中选择否即可将工程恢复到新的工程路径下。

返回

13、如何设置工程分辨率，以便与电脑匹配？

(1) 连接工程后，双击打开工程时，软件自动提示“是否转换分辨率”，选择“是”即可。

(2) 也可通过“工程项目管理器”菜单中“转换”按钮来实现工程分辨率的适配。

返回

14、请简单介绍一下实际工程？

实际用户工程项目由“工程项目管理器”管理，是用户根据现场的工艺要求，用世纪星开发的用户工程，其中包括“画面”、“变量”、“历史数据”及“命令语言”等，不包括开发环境、运行环境及其他工具。因此，一个完整的现场运行系统包括两个部分：一是“世纪星组态软件”(缺省：C:\CenturyStar)；二是“用户工程项目”（如： C:\新工程）。

返回

15、一套软件能运行多个工程吗？

世纪星的“工程项目管理器”可以管理多个用户工程项目，每次只能选择一个用户工程项目作为当前的工程项目，因此，在电脑上只能运行一个工程项目。

返回

16、不同分辨率的画面文件如何转换，如640*480的画面怎样转化成800*600？

(1) 确定当前工程项目中画面的分辨率是：640*480，如果不是，可以通过工程项目管理器中的分辨率转换对话框，修改当前工程项目的画面分辨率。

(2) 通过工程项目管理器中的分辨率转换对话框，设置转换后的画面分辨率为：800*600 ，按“转换”按钮即可。

返回

17、开发新的工程项目时，如何借助其它工程项目中的内容？

(1) 变量字典：通过 “工程项目管理器” 中 “导出” 和 “导入” 功能，将其它工程项目中的变量字典部分或全部导入。

(2) 画面文件：通过菜单 “文件” -- “导入画面”，可以将其它工程项目中的画面导入。

(3) 其它文件：在线帮助(开发系统中按 F1 键)中，最后一项是 “文件格式说明”，根据这个说明，可以将其它工程项目中需要的文件复制到新的工程项目中。注意：复制文件前，确保其它工程项目和新的工程项目没有加密，或者说：复制前，要去掉其它工程项目和新的工程项目的 “保护” 密码。复制其它工程项目中的文件，示例如下：

A： CSUSERS.DAT -- 用户配置文件。复制后，新的工程项目与其它工程项目中用户配置信息相同。

B：DATACHG.MAN、DATACHG.SPT -- 数据变化命令语言管理的信息和命令语言内容。 复制后，新的工程项目与其它工程项目中数据变化命令语言相同。

C：DEVICE.DRV -- I/O设备的所有信息。 复制后，新的工程项目与其它工程项目中驱动设备相同。

......

注释：有些功能由多个文件组成，这些文件的文件名称相同，扩展名不同，这时，需要将这些文件都复制。如上述 B 中 “数据变化命令语言” 是由 2 个文件组成：DATACHG.MAN、DATACHG.SPT 。

返回

18、老版本用户工程项目升级时，需要注意哪些方面？

升级前，用老版本软件打开用户工程项目，完成以下工作：

(1) 在 “工程项目管理” 中，去掉工程项目 “保护” 密码（即：设置为空）。

(2) 在 “工程项目管理” 中，将变量字典 “导出”，再直接 “导入”。

(3) 打开所有画面，选择 “全部保存”，关闭所有画面。

(4) 版本相隔时间较长（如：十年前的工程项目）的工程项目需要：删除 “历史曲线窗口” 和 “报警窗口”。删除前请记住他们的配置。

(5) 在 “驱动设备管理” 中，记下各个设备的参数，删除所有设备。

(6) 在用户工程项目目录中，删除用户配置文件：CSUSERS.DAT。删除前请记住他们的配置。

升级中，操作步骤如下：

(1) 在 “工程项目管理器” 中，将老版本用户工程项目 “连接” 进来，双击工程项目名称，按照系统提示进行升级操作。注意：升级时，新的工程项目不能与老版本用户工程项目在同一个目录中。

(2) 将升级后的工程项目 “连接” 进来，双击进入工程项目。

升级后，需要修改的内容如下：

(1) 在 “驱动设备管理” 中，创建所有设备，并设置相应的参数。

(2) 如果删除了 “历史曲线窗口” 和 “报警窗口”，需要重新绘制。

(3) “历史曲线窗口” 和 “报警窗口” 的部分函数已经升级，请查找修改。可以用画面编译、命令语言 “全部编译” 功能。

(4) “ODBC” 的部分函数已经升级，请查找修改。可以用画面编译、命令语言 “全部编译” 功能。

(5) “用户菜单” 功能已经升级，请查找修改。为了实现多级菜单，新版本已经不再使用系统变量：$用户菜单。注意：原菜单命令语言都在第一个菜单项中，只需要去掉系统变量：$用户菜单，将命令语言移到相应的菜单项命令语言中即可。

(6) 由于增加 “文本” 字体自动缩放功能，可能部分文本会显示不完整，如：“温度值” 显示成 “温度...”，需要增加文本的宽度。

(7) 重新配置用户。这部分修改是因为增加了 “安全区” 和 “访问级别” 双重保护功能。


系统配置

开发系统

  1. 开发系统与运行系统的区别？

  2. 开发系统有哪些个性化设置？

  3. 开发系统有工具箱吗？

  4. 开发系统有两个菜单，有什么区别？

  5. 如何修改开发系统主窗口的标题？

  6. 使用开发系统时，发现“浏览器”不见了，如何找回？

1、开发系统与运行系统的区别？

(1) 开发系统是其应用程序的集成开发环境。软件开发者在这个环境中完成图形界面的设计、变量数据库定义、动画连接等。开发系统具有先进完善的图形生成功能；变量数据库中有多种数据类型，能合理地抽象地控制对象的特性，对数据的报警、趋势曲线、历史数据记录、安全管理等重要功能有简单的操作方法。利用图形控件功能可以大大减少界面的设计时间，加快软件的开发进度。

(2) 运行系统是组态软件的实时运行环境，用于显示开发系统中建立的动画图形画面、同 I/O 服务程序进行数据交换。它通过实时数据库管理从工业控制对象采集到的各种数据，把数据的变化用动画的方式形象地表示出来，同时完成报警、历史数据记录、趋势曲线等功能。

返回

2、开发系统有哪些个性化设置？

开发系统中，用户可以设置自己的组态开发界面，主要有：

(1) 动态浏览器：提供最大化的工作空间；

(2) 自定义菜单、工具栏：用户可以增加、减少菜单和工具栏的项目，还可以新增工具栏，创建自己专用的工具栏项目；

(3) 工具编辑：用户可以增加、删除常用工具，如：notepad.exe、mspaint.exe 等。

返回

3、开发系统有工具箱吗？

开发系统提供工具栏和工具箱，用户可以根据自己的喜好选择使用。

系统包含六个工具栏：常用工具栏、绘图工具栏、属性工具栏、文字工具栏、排列工具栏和视图工具栏。

工具箱是将六个工具栏的快捷按钮集中到一个工具箱中，方便用户选择使用。

返回

4、开发系统有两个菜单，有什么区别？

在开发系统中，主窗口提供两个菜单：

(1) 画面打开前的菜单，或者没有画面打开时的菜单，菜单项是与系统功能相关的菜单，如菜单项：工程项目管理器、编译画面、变量使用查询等。

(2) 画面打开后的菜单，或者有画面打开时的菜单，菜单项是与画面编辑功能相关的菜单，如菜单项：绘制直线、改变文本、向左对齐等。

返回

5、如何修改开发系统主窗口的标题？

在菜单“系统” -- “系统配置” -- “开发系统配置”中设置，改变“标题”的内容，就改变了开发系统主窗口的标题。

返回

6、使用开发系统时，发现“浏览器”不见了，如何找回？

开发系统中，有些工具栏或浏览器等不见了，有两种方法可以找回：

(1) 在开发系统左下角视图工具栏中，点击“浏览器”按钮，可以显示或隐藏“浏览器”;或者，在系统菜单“查看”中，点击“浏览器”菜单项，可以显示或隐藏“浏览器”。

(2) 关闭开发系统，在系统“开始”菜单中点击“运行”，输入系统注册表编辑命令：regedit，在注册表中找到注册项：HKEY_CURRENT_USER\Software\北京世纪长秋科技有限公司，用鼠标右键点击弹出菜单，选择“删除”，关闭注册表，再次运行开发系统，开发系统的菜单、工具栏、浏览器等恢复到安装软件时缺省状态。


变量字典

  1. 什么是变量字典？

  2. 什么是系统变量？

  3. 内存变量、I/O变量和引用变量的区别？

  4. 什么是特殊变量？

  5. 变量的只读、读写、只写属性各代表什么意思？

  6. 变量的数据类型（离散、整数、实数，信息值）各是什么意思？

  7. 变量的转换方式怎么用？

  8. 变量的初始值、最小值、最大值、最小I/O值、最大I/O值各代表什么意思？

  9. 什么是变量的数据死区？

  10. 世纪星变量的定时记录和死区记录是什么意思？

  11. 如何快速创建变量？或如何用 EXCEL创建变量？

  12. 如何在系统退出时保存当前变量的数值？

  13. 变量字典中保存值和保存参数是什么意思？

  14. 为什么变量字典中“保存值”和“保存参数”经常不起作用？

  15. 如何删除变量？

  16. 已经删除了变量的所有连接，为什么在变量字典中的变量还是灰色的，不能修改或删除？

  17. 系统支持的最大点数是多少？

  18. 设备对象名、寄存器、数据类型、采集频率代表什么意思？

1、什么是变量字典？

变量字典是系统中所有变量的集合，由一个个变量组成，每个变量都有自己的名称、描述、变量类型等属性。

在开发系统中，变量字典中包含所有变量的列表，用户可以创建、修改或删除这些变量。

变量字典中的变量有五种类型：系统变量、内存变量、IO变量、引用变量和特殊变量。

返回

2、什么是系统变量？

系统变量是系统预先设置的变量，不需要用户创建，这些变量用户可以直接使用。系统变量又分为系统离散、系统整数、系统实数、系统信息和系统报警组变量。系统变量设有只读和读写属性，只读变量如系统时间等，由系统自动更新，用户不能改变这些变量的数值；对于具有读写属性的系统变量，用户可以改变变量的数值。

返回

3、内存变量、I/O变量和引用变量区别？

(1) 内存变量：用户定义在系统内部的变量，这些变量不同外部进行数据交换，主要存放计算处理的中间值，以及在系统仿真时模拟IO变量。

(2) IO变量：与其他应用程序进行数据交换的变量。

(3) 引用变量：就是指针变量，可以实现对其他变量的引用，一旦引用操作发生，引用变量将具有和被引用变量相同的特性。

返回

4、什么是特殊变量？

特殊变量是系统为实现一些特殊功能而设置的变量，特殊变量类型包含三种变量：报警窗口变量、历史曲线变量和报警组变量。

(1) 报警窗口变量：同报警窗口控件关联，用于唯一标识报警窗口控件。报警窗口变量的域可用于获取报警窗口控件的参数，也可以通过设置报警窗口变量的域值，改变报警窗口控件的参数。

(2) 历史曲线变量：同历史曲线控件关联，用于唯一标识历史曲线控件。历史曲线变量的域可用于获取历史曲线控件的参数，也可以通过设置历史曲线变量的域值，改变历史曲线控件的参数。

(3) 组变量：即报警组变量，用于确定各个报警组之间的父子、兄弟关系。组变量的域如：.Ack、.Alarm 可以表示该报警组的报警状态及是否应答等信息。

返回

5、变量的只读、读写、只写属性各代表什么意思？

只有IO类型的变量才具有只读、读写或只写属性。

(1) 只读：表示变量的值只能从外部设备读取，不可以写到外部设备。

(2) 读写：表示变量的值可以从外部设备读取，也可以写到外部设备。

(3) 只写：表示变量的值只能写到外部设备，不可以从外部设备读取。

返回

6、变量的数据类型（离散、整数、实数，信息值）各是什么意思？

系统变量、内存变量、IO变量和引用变量都有四种数据类型：

(1) 离散类型变量：布尔变量，就是开关量。离散类型变量的值只能为：0（关，OFF，FALSE）和1（开、ON，TRUE）两种。

(2) 整数类型变量：32位整数变量。取值范围：-2,147,483,648 ～ 2,147,483,647。

(3) 实数类型变量：十进制浮点型变量。取值范围：-3.4e 38 ～ 3.4e 38。

(4) 信息类型变量：字符串变量。取值范围：最长能存储255个字符。

返回

7、变量的转换方式怎么用？

数据转换方式是IO整数和IO实数对应外部数据的原始数值到数据库中数值的转换方式，包括以下两种基本数据转换方式：

(1) 线性：IO整数和IO实数对应的原始数值和数据库使用值用线性插值进行转换。

(2) 开方：用IO整数和IO实数对应的原始数值的平方根进行转换。

数据转换方式可以用于采集数据和变量数据库中对应值之间单位换算。

示例：（1）用板卡采集温度0~100℃，由于从板卡上获取的是数字信号，范围：0~32767，为了显示温度值，就必须进行线性转换，这样在计算机上就显示温度0~100℃。

（2）在变量字典中实现上述线性转换的设置方法：最小值=0；最大值=100；最小[IO]值=0；最大[IO]值=32767。

返回

8、变量的初始值、最小值、最大值、最小I/O值、最大I/O值各代表什么意思？

(1) 初始值：系统开始运行时为变量设置的初值。

(2) 最小值：变量数据库中变量的最小值。

(3) 最大值：变量数据库中变量的最大值。

(4) 最小值[I/O]：变量对应外部设备或应用程序的最小值。

(5) 最大值[I/O]：变量对应外部设备或应用程序的最小值。

返回

9、什么是变量的数据死区？

数据死区：变量的值改变时，为防止数据抖动而设置的一个数据区域，当数据变化在这个数据区域范围（“当前值-数据死区” -- “当前值+数据死区”）内时，系统认为数据没有发生改变；当该数据变量的值变化幅度达到或超过数据区域范围（“当前值-数据死区” -- “当前值+数据死区”）内时，系统才更新变量的值。

数据类型为整数类型、实数类型时才有“数据死区”的选项。

返回

10、世纪星的定时记录和死区记录是什么意思？

系统运行时，将变量的值按照时间顺序保存到磁盘上，生成历史数据记录，离散类型、整数类型和实数类型的变量可以选择是否记录。数据记录包括三种记录方式：不记录、死区记录、定时记录：

(1) 不记录：变量的值不需要历史记录。

(2) 定时记录：变量的值按照设置的时间间隔记录到磁盘上。

(3) 死区记录：变量值的变化幅度大于或等于设定的“记录死区”值时，才被记录到磁盘上。

死区记录示例：温度变量，内存实数类型，选择死区记录方式，记录死区 = 3。系统运行时，温度的初始值是10，当温度的值为12时，由于12-10 = 2 < 3，数据变化的幅度小于“死区记录”值，不记录；当温度的值为14时，由于14-10 = 4 > 3，数据变化的幅度大于“死区记录”值，记录到磁盘上。

注释：(1) 在精度允许的范围内，建议尽量采用“死区记录”，这样保存的数据量会小些，可以提高系统的运行效率。

(2) 定时记录应用场合：要求数据记录的时间间隔比较长，如：1分钟以上记录一次数据。

返回

11、如何快速创建变量？或如何用 EXCEL创建变量？

(1) 在“工程项目管理器”中指定用户工程项目，在上面的工具按钮中按“导出”按钮，将工程项目的变量字典导出到CSV格式的文件。

(2) 用EXCEL 编辑CSV文件。注意：每种数据类型改变时，都有一行标题，用于标识下面变量的数据类型及每列的内容，这个标题不要修改或删除，否则，无法“导入”到系统中。

(3) 在“工程项目管理器”中指定用户工程项目，在上面的工具按钮中按“导入”按钮，将刚编辑的CSV文件导入到工程项目的变量字典中。

(4) 在“工程项目管理器”中用鼠标左键双击工程项目或在工具按钮中选择“打开”按钮，新导入的变量字典将重新加载到系统中。

注释：

(1) 使用导出/导入功能时，至少要创建一个需要的变量，确保在EXCEL中有这种变量类型的标题。

(2) 变量字典在导入时，会做合法性检查，如：变量名称是否合法；变量名称是否重名等。

返回

12、如何在系统退出时保存当前变量的数值？

(1) 在定义变量的时候选择保存变量值；

(2) 用函数 FileWriteFields() 保存变量值，在下次调用时，用函数 FileReadFields() 读取。

返回

13、变量字典中保存值和保存参数是什么意思？

保存值：选中本项，在运行系统退出时，将变量的值保存到变量的初始值中，这样，下次运行系统启动时，变量的值为上次系统运行退出时系统保存的值。

保存参数：在系统运行时，修改变量域的值（读写属性的域），当系统退出时，系统将这些变化的域值保存到变量字典中，下次运行系统启动时，就会使用这些域值。

注：由于保存值和保存参数可以改变变量的参数值，开发系统中变量字典编辑时，也可以修改变量的参数值，因此，系统规定：在开发系统打开时，运行系统中“保存值”和“保存参数”的功能无效！

返回

14、为什么变量字典中“保存值”和“保存参数”经常不起作用？

(1) “保存值”和“保存参数”含义： 保存值：运行系统关闭时，将变量的值保存到变量的初始值中，这样，下次再打开运行系统时，变量的值就会跟上次关闭运行系统时的值一致。

保存参数：运行系统关闭时，将变量的一些域值保存到变量的相应的域中，如：报警上限等，如果运行中用户改变过变量的域值，就会将这些值保存到变量字典中，下次再打开运行系统时，变量的域值就会跟上次关闭运行系统时的域值一致。

(2) 由于上述值都是保存到变量字典中，而开发系统又可以随时修改这些值，如果运行系统关闭后，开发系统中又修改了这个变量，就会引起“保存值”和“保存参数”不起作用。

因此，系统规定：只有关闭开发系统后，“保存值”和“保存参数”才起作用，否则，忽略“保存值”和“保存参数”的功能。

返回

15、如何删除变量？

在开发系统中，已经使用过的变量是不能修改变量名称，或者删除这个变量。删除变量方法：

(1) 关闭所有画面。

(2) 在菜单“系统”中选择“变量使用查询”可以查询到所有使用该变量的地方，将这些使用的地方(如：动画连接或命令语言)去掉该变量

(3) 在菜单“系统”中选择“更新变量计数”。

(4) 在菜单“系统”中选择“删除未用变量”将变量删除。

返回

16、已经删除了变量的所有连接，为什么在变量字典中的变量还是灰色的，不能修改或删除？

系统中已经使用过的变量，在变量字典中显示的变量名称就是灰色的，表示不能修改或删除。要想修改或删除这些变量，必须做到：

(1) 关闭所有画面。

(2) 在菜单“系统”中选择“变量使用查询”可以查询到所有使用该变量的地方，将这些地方(如：动画连接或命令语言中)的变量删除。

(3) 在菜单“系统”中选择“更新变量计数”。

(4) 这时，变量就可以修改或删除了。

返回

17、系统支持的最大点数是多少？

世纪星支持的最大点数为6万点。

返回

18、设备对象名、寄存器、数据类型、采集频率代表什么意思？

变量字典中“设备对象名”、“寄存器”都需要选择设置，不能直接输入，因为，选择时，与选择项相关的参数将会自动调入。在“设备对象名”下拉式列表框中选择相应的设备对象，本设备支持的所有寄存器将自动设置到寄存器下拉式列表框中；在“寄存器”下拉式列表中选择一个寄存器，则寄存器支持的数据类型、读写属性等参数会设置到变量的相应属性中。

(1) 设备对象名：在设备管理器中已经创建的设备名称，该名称为所连接设备的标识。

(2) 寄存器：设备中包含的寄存器。

(3) 数据类型：寄存器在设备中的数据类型。

(4) 采集频率：从设备中采集本寄存器值的频率。


画面编辑

  1. 画面窗口的覆盖式、替换式、弹出式有何区别？怎么用？

  2. 状态行编辑如何使用？

  3. 演示系统中下拉菜单是怎么实现的？

  4. 世纪星中位图透明的方法？

  5. 演示工程的立体效果如何实现的？

  6. 改变多边线的各顶点的位置时，如何才能使移动位置精确？

  7. 如何把一个工程做的图素拿到其他工程上用？

  8. 如何把位图添加到图库中？

  9. 一个合成单元能和其他单个图素合成一个单元吗？

  10. 如何修改单元内的图素的大小和图素的动画连接？

  11. 如何把世纪星的内存整数变量值在画面显示出来？

  12. 如果一个画面中，静态图素或渐进色很多对画面刷新有影响吗，需要做什么处理？

  13. 如何把外部图形文件导入画面？

  14. 演示工程中的有些功能我想借鉴，如何做？

  15. 为什么有时候画的图素在填充时没有改变颜色？

  16. 为什么画多边形出现的是折线？

  17. 开发系统中，图素颜色和背景色发生混乱？

  18. 怎样将裁剪板中的图像粘贴到世纪星的画面中？

  19. 画面中的数字、文本显示等如何根据值的不同用不同的颜色显示？

  20. 画直线时，怎样保证其水平和垂直？

  21. 如何复制运行画面？

  22. 世纪星画面制作的小技巧有哪些？

  23. 一个工程项目中最多能做几幅画面？

  24. 世纪星的画面支持多屏显示码？如何设置？

  25. 不分裂单元或块，可以编辑单元或块内的图素吗？

1、画面窗口的覆盖式、替换式、弹出式有何区别？怎么用？

(1) 覆盖式画面：它重叠在当前画面之上。关闭后被覆盖的画面又可见。

(2) 替换式画面：显示时，所有与之相交的画面自动从屏幕上和内存中删除。建议尽量使用“替换式”画面以节约内存。

(3) 弹出式画面：类似于“覆盖式”画面，总显示在画面的最前面，一般用于对话框或提示信息显示。

注释：

(1) 画面窗口尽量选择“替换式画面”，可以节省内存，提高运行速度。

(2) 如果选择“覆盖式画面”，则要记住每次打开的画面名称，在打开另一幅画面前，要先关闭以前打开的画面。示例见：DemoProject。

返回

2、状态行编辑如何使用？

在画面中，选择一个图素或单元时，可以用状态行编辑左上角坐标及大小：用鼠标左键双击状态行的坐标或大小显示区域，可以直接修改图素或单元的坐标或大小，按“回车”键后，修改完成；按其它键或用鼠标点击其它区域，则取消状态行编辑操作。

返回

3、演示系统中下拉菜单是怎么实现的？

开发系统提供“菜单”绘制功能，在主菜单的“绘制”菜单中选择“菜单”项就可以在画面中绘制一个菜单，双击这个菜单弹出“菜单编辑”对话框，可以编辑需要显示的菜单项，双击菜单项可以编辑每个菜单对应的命令语言。

返回

4、世纪星中位图透明的方法？

单选位图，按鼠标右键，在弹出的菜单中选择“图像属性”，在“图像属性”中可以选择单色透明：对图像中单个颜色透明；整体透明：为整个图像设置透明度。

返回

5、演示工程的立体效果如何实现的？

通过矩形、圆角矩形、椭圆等图素组合实现，对于每个图素，按鼠标右键，在弹出的菜单中选择“填充属性”，根据需要选择“渐进填充”、“圆心填充”等。演示工程中的每个单元或块都是可以分裂的，可以将一个单元分裂后，看看是由哪些图素组成，每个图素是如何通过“填充属性”实现的。

返回

6、改变多边线的各顶点的位置时，如何才能使移动位置精确？

用“编辑”菜单中的“改变图素形状”功能，就可以增加/删除多边形的顶点，也可以移动各个顶点的位置。要精确定位各个顶点的位置，可以用键盘上的光标移动键移动选中的顶点，键盘移动的遵守如下：

(1) 微调：用光标键 LEFT,TOP,RIGHT,BOTTOM 每次移动1个象素。

(2) 细调：用Shift键+光标键 LEFT,TOP,RIGHT,BOTTOM 每次移动10个象素。

(3) 粗调：用Ctrl键+光标键 LEFT,TOP,RIGHT,BOTTOM 每次移动50个象素。

返回

7、如何把一个工程做的图素拿到其他工程上用？

系统提供用户自定义图库功能：将图素合成一个单元，添加到自定义图库中，这样，其他工程就可以调用这个图库。

返回

8、如何把位图添加到图库中？

系统提供用户自定义图库功能：将位图合成单元，就可以添加到自定义图库中。

返回

9、一个合成单元能和其他单个图素合成一个单元吗？

可以，图素可以合成单元，单元与图素或单元又可以合成块，块与图素、单元和块又可以合成新的块，可以一直合成下去。

返回

10、如何修改单元内的图素的大小和图素的动画连接？

不用“分裂单元”就可以修改单元内图素的大小和动画连接，方法如下：

(1) 在浏览器中，每个画面可以用鼠标右键弹出菜单，选择“画面图素”菜单项，可以查看画面中所有图形的图素树，点画面中的单元，对应“图素树”中单元名称项会选中，展开单元项，单元内所有的图素都可以看见。

(2) 修改图素：点击要修改的图素，画面中的单元出现红色的虚线边框，选中的图素会出现选中框，直接修改。

(3) 修改图素的动画连接：在“图素树”中，每个名称前有中括号“[ ]”，其中的数字表示本图素或单元包含动画连接的数量，双击图素或单元，可以增加或修改动画连接。

返回

11、如何把世纪星的内存整数变量值在画面显示出来？

先绘制文本，为画面整齐美观，数值显示用"####"显示，双击文本弹出动画连接对话框，选择“模拟量显示”，可以将内存整数变量值与文本建立连接，运行时就可以显示变量值。

返回

12、如果一个画面中，静态图素或渐进色很多对画面刷新有影响吗，需要做什么处理？

任何软件在画面复杂时，显示都会有一定的影响，严重时会影响整个系统的运行。如果觉得画面打开的速度较慢，可以使用“从屏幕抓取点位图”功能，将比较复杂的单元变成一个位图，原图以备份画面的形式保存起来，这样，画面刷新的效果会明显提高，系统的整体性能也会提高。

返回

13、如何把外部图形文件导入画面？

系统提供“导入图像”功能，可以将多种图像格式的文件导入到位图中。

返回

14、演示工程中的有些功能我想借鉴，如何做？

系统提供“导入画面”功能，可以将其他工程项目中的画面导入到本工程项目中。

返回

15、为什么有时候画的图素在填充时没有改变颜色？

在“填充属性”对话框中，选择了“透明填充”。

返回

16、为什么画多边形出现的是折线？

在“填充属性”对话框中，选择了“透明填充”。

返回

17、开发系统中，图素颜色和背景色发生混乱？

一般与显卡性能有关，很多时候如果颜色设置是真彩色（32位）的话，改为增强色（16位）后即可恢复正常。【建议关闭3D加速引擎】

返回

18、怎样将裁剪板中的图像粘贴到世纪星的画面中？

在系统的工具箱中选择绘制位图，在画面上绘制一个位图，点击鼠标右键，选择“粘贴点位图”即可。

返回

19、画面中的数字、文本显示等如何根据值的不同用不同的颜色显示？

在显示的文本的动画连接中选择文本色，输入显示的变量名称，在文本色属性栏中添加、修改或删除不同阈值时要显示的不同颜色。

返回

20、画直线时，怎样保证其水平和垂直？

(1) 可以选择画水平垂线和垂直垂线。

(2) 画直线时，选择“显示栅格”，这样画直线时会自动对齐栅格线，水平、垂直直线就很好画了。

返回

21、如何复制运行画面？

在运行时按下键盘上的屏幕拷贝键（PrtSc），在画图软件中使用粘贴即可。

返回

22、世纪星画面制作的小技巧有哪些？

(1) 按住Shift键可画正圆，正方形，正圆角距形，正斜线（45。）。

(2) 按住Ctrl 键可选定多个图素。

(3) 可以使用很多组合键，以加快工作进程，如Ctrl+A全选、Ctrl+C复制、Ctrl+V拷贝等。

(4) 用渐进色，透明点位图从屏幕抓取点位图等作一些特殊效果。如管道接口，文本效果等。

(5) 常用鼠标右键选择功能，双击图素进行动画连接。

返回

23、一个工程项目中最多能做几幅画面？

一个工程项目最多能做1024幅画面。

返回

24、世纪星的画面支持多屏显示码？如何设置？

在计算机上安装多屏显示卡，就可以支持多屏显示，通过设置画面的左上角坐标实现多屏显示。

返回

25、不分裂单元或块，可以编辑单元或块内的图素吗？

可以。使用 “画面图素” 功能，操作步骤如下：

(1) 在浏览器中，用鼠标右键单击图素所在的画面，弹出右键菜单，选择 “画面图素”，画面下面显示出 “图素树”。

(2) 用鼠标左键点击画面中单元或块，可以找到 “图素树” 中对应的 GROUP。

(3) 展开 GROUP 的 “图素树” 可以看到单元或块内的图素，用鼠标左键单击选中，在画面中会显示选中框 。

(4) 可以编辑单元或块内图素的形状大小，也可以编辑单元或块内图素的动画连接。


动画连接

  1. 什么是动画连接？

  2. 风扇的叶片旋转是怎么实现？

  3. 如何在运行时改变内存整数变量的值？

  4. 画面中的数字、文本显示等如何根据值的不同用不同的颜色显示？

1、什么是动画连接？

动画连接就是建立画面的图素与数据库变量的对应关系。工业现场的数据，比如温度、液面高度等，当它们变化时，通过I/O接口，将引起实时数据库中变量的变化，如果设计者曾经定义了一个画面图素比如指针与这个变量相关，将会看到指针在同步偏转。

动画连接的引入是设计者人机接口的一次突破，它把程序员从重复的图形编程中解放出来，为程序员提供了标准的工业控制图形界面，并且有可编程的命令语言连接来增强图形界面的功能。图形对象与变量之间有丰富的连接类型，给程序员设计图形界面提供了极大的方便。

返回

2、风扇的叶片旋转是怎么实现？

绘制风扇叶片的多个状态，即多张风扇叶片，每张风扇叶片处于不同的位置，按照旋转显示的顺序对每个叶片增加“可见/隐含”连接，运行时，依次显示各个叶片，像放电影一样，达到叶片的旋转。

运算符“%”是取运算结果的余数，示例：有3个叶片，对应的内存整数变量为“叶片状态”，可以用变量“叶片状态”除３的余数，即：“叶片状态%3”表示。第一个叶片“可见/隐藏”表达式：叶片状态%3==0; 第二个叶片“可见/隐藏”表达式：叶片状态%3==1；第三个叶片“可见/隐藏”表达式：叶片状态%3==2。

返回

３、如何在运行时改变内存整数变量的值？

通过动画连接中“模拟量输入”连接实现：先绘制文本，为画面整齐美观，数值显示用"####"显示，双击文本弹出动画连接对话框，选择“模拟量输入”，可以将内存整数变量值与文本建立连接，运行时，单击文本就可以改变变量值。

返回

４、画面中的数字、文本显示等如何根据值的不同用不同的颜色显示？

通过动画连接中“文本属性”连接实现：在弹出的“文本属性”对话框中，设置变量或表达式对应的值，每个值对应一个颜色，运行时，文本的颜色就会随着数值的变化而改变。


命令语言

  1. 应用程序命令语言、事件命令语言、数据改变命令语言的差别？

  2. 功能块命令语言如何使用？

  3. 希望一个变量“计数”每分钟加1，怎么实现？

  4. 如何在实现定时打印？

  5. 高速命令语言怎么用？

  6. 能否不通过菜单，用按钮调出登录窗口？

  7. 脚本编译时出现错误提示，如何快速定位错误行？

  8. 如何在运行时用F1键调出帮助画面？

  9. WEB命令语言怎么用？

1、应用程序命令语言、事件命令语言、数据改变命令语言的差别？

三种命令语言主要在：启动、运行、关闭的时机上有差别，如下：

(1) 应用程序命令语言：在程序启动时执行、关闭时执行或者在程序运行期间定时执行。

(2) 事件命令语言：在事件发生、存在、和消失时分别执行的程序。离散变量名或表达式都可以作为事件。

(3) 数据改变命令语言：连接到变量或变量的域。在变量或变量的域的值变化到超出变量字典中所定义的变化灵敏度时，它们就被执行一次。

返回

2、功能块命令语言如何使用？

功能块命令语言相当于子命令语言，由函数CallFunctionBlock()调用，常用于以下场合：

(1) 如果一段命令语言被多次调用，可以用功能块命令语言取代。

(2) 命令语言很长时，为便于查看，可以将一部分转移到功能块命令语言中。

(3) 控件中有些功能，必须用功能块命令语言实现。

返回

3、希望一个变量“计数”每分钟加1，怎么实现？

用“数据改变命令语言”实现。在数据改变命令语言的对话框中，“变量.[域]”中使用系统变量：$分,命令语言中设置：

计数=计数+1;

原理：系统变量$分每分钟变化一次，命令语言就会执行一次，就实现了变量“计数”每分钟加1。

返回

4、如何在实现定时打印？

有两种方法可以实现定时打印：

(1) 用“事件命令语言”实现。在事件命令语言中，用时间作为事件，当事件发生时，调用函数实现定时打印。

示例：每天上午8:00打印一次，则事件命令语言的“事件描述”：

($时==8)&&($分==0)&&($秒==0) 命令语言中调用打印函数。

(2) 用“应用程序(运行时)命令语言”实现。

示例：每天上午8:00打印一次，则在应用程序(运行时)命令语言增加：

IF ($时==8)&&($分==0)&&($秒==0) THEN

{ 打印函数 }

ENDIF;

返回

5、高速命令语言怎么用？

高速命令语言相当于后台命令语言，通过系统变量“$启动高速命令语言”控制命令语言的执行。

(1) $启动高速命令语言=1时，高速命令语言开始定时执行;

(2) $启动高速命令语言=0时，高速命令语言停止运行。

返回

6、能否不通过菜单，用按钮调出登录窗口？

在按钮命令语言中，有两种方法可以调出用户登录窗口：

(1) 给系统变量赋值：$用户登录=1；

(2) 调用函数 LogOn() 。

返回

7、脚本编译时出现错误提示，如何快速定位错误行？

在命令语言中，编译出错信息显示在对话框的右下角中，用鼠标右键双击出错信息的某一行，编缉框中光标会定位到出错信息对应的行中。

返回

8、如何在运行时用F1键调出帮助画面？

用“热键改变命令语言”实现。在热键命令语言对话框中，选择F1热键，“热键状态”选择：热键按下时，命令语言中设置：

ShowWindow("帮助画面")；

返回

9、WEB命令语言怎么用？

WEB 命令语言是 WEB 客户端定时执行的命令语言。

WEB发布后，除按钮命令语言外，客户端的应用程序不执行：应用程序命令语言、事件命令语言、数据改变命令语言、热键命令语言。

WEB 命令语言用于动画显示，或只与客户端操作相关的命令语言。注意：接收赋值的变量不能选择“WEB发布”，因为，选择“WEB发布”变量的值与“WEB服务器”中变量的始终保持一致。


函数

  1. 什么是函数？函数怎么使用？

  2. 是否有定时器、计时器、 计数器功能函数？

  3. 如何把变量值保存到文件中？

  4. 如何对一个实数变量取位？

  5. 如何对一个整数变量置位？

  6. 如何进行置位及取位？

  7. 如何实现语音报警？

  8. 如何实现通过播放WAV文件实现报警？

  9. 如何在系统中调用 VC 程序？

  10. 怎样将十进制数在数据库中转换成十六进制数？

  11. 能否用命令语言操作并口、串口、I/O口？

  12. 能否实现针式打印机行打印？

  13. 调用端口函数（IO_开头），是否可以实现对板卡操作？

1、什么是函数？函数怎么使用？

函数是系统内置的功能模块，用于实现一些特定的功能。根据函数用途可以分为以下几类：系统函数、SQL函数、字符串函数、数学函数、控件函数、定制函数等。

函数用法：用于命令语言和动画连接的表达式中。使用函数时，需要注意一下几点：

(1) 对于不太熟悉的函数，可以用“按钮命令语言”测试函数的使用效果，要注意函数的参数及返回值。

(2) 大部分函数的参数都可以直接使用数值(或字符串)作为参数，也可以用数据类型相对应的变量作为参数。

返回

2、是否有定时器、计时器、 计数器功能函数？

(1) 有，定时器函数：Timer( )；计时器函数：TimeCounter( )；计数器函数：Counter( )。

(2) 函数帮助：开发系统中，选择：“函数” -- “其它函数”。

(3) 命令语言中函数帮助：命令语言编辑器中，双击函数名称，弹出本函数的帮助窗口。

返回

3、如何把变量值保存到文件中？

(1) 用函数：FileCSVWrite()、FileWriteFields() 、FileWriteMessage()、FileWriteTags()。

(2) 函数帮助：开发系统中，选择：“函数” -- “文件操作函数”。

(3) 命令语言中函数帮助：命令语言编辑器中，双击函数名称，弹出本函数的帮助窗口。

返回

4、如何对一个实数变量取位？

(1) 先用Int() 函数对实数值取整，再用Bit() 函数。

(2) 函数帮助：开发系统中，Int() 函数帮助选择：“函数” -- “数学函数”；Bit() 函数帮助选择：“函数” -- “其它函数”。

(3) 命令语言中函数帮助：命令语言编辑器中，双击函数名称，弹出本函数的帮助窗口。

返回

5、如何对一个整数变量置位？

(1) 函数 BitSet()：设置整数变量某位的值。

(2) 函数帮助：开发系统中，选择：“函数” -- “其它函数”。

(3) 命令语言中函数帮助：命令语言编辑器中，双击函数名称，弹出本函数的帮助窗口。

返回

6、如何进行置位及取位？

(1) 函数 Bit()：获得整数变量某位的值。

(2) 函数 BitSet()：设置整数变量某位的值。

(3) 函数帮助：开发系统中，选择：“函数” -- “其它函数”。

(4) 命令语言中函数帮助：命令语言编辑器中，双击函数名称，弹出本函数的帮助窗口。

返回

7、如何实现语音报警？

(1) 使用 Voice() 函数，将信息用标准普通话语音输出。

(2) 函数帮助：开发系统中，选择：“函数” -- “其它函数”。

(3) 命令语言中函数帮助：命令语言编辑器中，双击函数名称，弹出本函数的帮助窗口。

注释：使用 Voice() 函数需要调用 Windows 的语言库，请注册 REG.reg 文件，文件在世纪星系统目录（缺省：C:\CenturyStar）中，用鼠标左键双击文件即可注册。

返回

8、如何实现通过播放WAV文件实现报警？

(1) 使用 PlaySound() 函数，电脑的声音设备(如果系统已安装)播放声音文件(.wav)。

(2) 函数帮助：开发系统中，选择：“函数” -- “其它函数”。

(3) 命令语言中函数帮助：命令语言编辑器中，双击函数名称，弹出本函数的帮助窗口。

返回

9、如何在世纪星中调用 VC 程序？

(1) 系统提供开放的数据接口程序(UserFunc)，用户可以编制自己的 VC 应用程序，通过 UserDll() 函数调用。

(2) 函数帮助：开发系统中，选择：“函数” -- “其它函数”--“UserDll()”。

(3) 命令语言中函数帮助：命令语言编辑器中，双击函数名称，弹出本函数的帮助窗口。

(4) 示例源程序和示例工程见：世纪星系统目录(缺省：C:\CenturyStar)中 Interface 目录。

返回

10、怎样将十进制数在数据库中转换成十六进制数？

通过字符串函数实现：

(1) 将十进制数转换成字符串，用函数：StringFromIntg(Number,Base),其中Number为要转换的数，它是一个数字或者一个整形变量；Base 为用来转换的进制）。

(2) 将字符串转换成16进制数，用函数：StringToIntg(Text)。

(3) 函数帮助：开发系统中，选择：“函数” -- “字符串操作函数”。

(4) 命令语言中函数帮助：命令语言编辑器中，双击函数名称，弹出本函数的帮助窗口。

返回

11、能否用命令语言操作并口、串口、I/O口？

通过函数可以对串并口和I/O口直接操作。

(1) 串并口函数：Port_Open( )、Port_Setup( )、Port_Read( )、Port_Write( )、Port_Close( )。

(2) I/O端口函数：IO_InitDriver( )、IO_ReadByte( )、IO_WriteByte( )、IO_CloseDriver( )。

(3) 函数帮助：开发系统中，选择：“函数” -- “串并口操作函数” 和 “IO端口操作函数”。

(4) 命令语言中函数帮助：命令语言编辑器中，双击函数名称，弹出本函数的帮助窗口。

返回

12、能否实现针式打印机行打印？

(1) 通过并口操作函数：Port_Open( )、Port_Write( )、Port_Close( )，向并口发送功能码，可以直接操作并口，实现打印功能。

(2) 函数帮助：开发系统中，选择：“函数” -- “串并口操作函数”。

(3) 命令语言中函数帮助：命令语言编辑器中，双击函数名称，弹出本函数的帮助窗口。

返回

13、调用端口函数（IO_开头），是否可以实现对板卡操作？

(1) 通过IO端口操作函数读写板卡数据：IO_InitDriver( )、IO_ReadByte( )、IO_WriteByte( )、IO_CloseDriver( )。

(2) 函数帮助：开发系统中，选择：“函数” -- “IO端口操作函数”。

(3) 命令语言中函数帮助：命令语言编辑器中，双击函数名称，弹出本函数的帮助窗口。


报警窗口

  1. 变量报警如何定义？

  2. 报警组怎么用？

  3. 变量报警优先级怎么用？

  4. 离散值报警怎么设置？

  5. 模拟值报警怎么设置？

  6. 模拟值报警限的低低、低、高、高高各代表什么意思，还和什么设置有关联？

  7. 模拟值的偏差报警如何设置？

  8. 变化率报警代表什么意思、如何设置？

  9. 为什么有些打印机在打印实时报警时打出的为乱码？

  10. 为什么我在变量字典中定义了报警记录，但却找不到的报警记录的文件，记录到哪去了，需要进行那些设置？

  11. 如何查询历史报警？

  12. 怎样产生声音报警？

  13. 系统中有很多报警，希望有一个变量报警就可以马上知道？

  14. 如何知道系统中有未应答的变量？

1、变量报警如何定义？

在变量字典中定义变量时，选中“允许报警”选项，开关量：设置离散值报警方式；模拟量：选择报警方式，设置对应的报警参数。

返回

2、报警组怎么用？

在系统中，为了方便查看，要将变量产生的报警信息归到不同的报警组中，即变量的报警信息属于某个规定的报警组。

报警组是按树状组织的结构，缺省时只有一个根节点，固定为$系统。可以通过报警组定义对话框为这个结构加入多个节点和子节点，每个节点是一个报警组，同时也是一个组变量。这类似于树状的目录结构，每个子节点报警组下所属的变量，属于该报警组的同时，属于其上一级父节点报警组。

在定义变量时，每个需要报警的变量都可以选择一个报警组。每个报警组变量都有域表示改组变量的报警状态和应答状态。

返回

3、变量报警优先级怎么用？

优先级是报警事件重要程度的度量，数字1的级别最高，999为最低级别，给每个要监视的变量规定一个报警优先级可以分层次管理报警事件。

返回

4、离散值报警怎么设置？

离散值报警分为关报警、开报警和无报警：

(1) 无报警：表示不报警。

(2) 关报警：表示当变量值为0时报警。

(3) 开报警：表示当变量值为1时报警。

返回

5、模拟值报警怎么设置？

在变量字典中，对模拟量选择报警，同时选择对应的报警限、偏差、变化率，这个模拟量就具有报警功能。

返回

6、模拟值报警限的低低、低、高、高高各代表什么意思，还和什么设置有关联？

报警限：变量报警的上下限，整数类型、实数类型的变量有四种报警可选项：低低、低、高、高高。在低低和低报警的情况下，每当变量值小于报警下限时就出现报警；在高高和高报警的情况下，每当变量值大于报警上限值时就出现报警。正常区域和报警区域的确定要根据低低，低，高，高高这四种报警设定值来进行。其确定示意图如下所示：

返回

7、模拟值的偏差报警如何设置？

偏差：是经模拟量相对目标值（基准值）上下波动的百分比来定义，有小偏差和大偏差两种报警条件，目标值（基准值）由后面编辑框输入。当波动的百分比小于小偏差或大于大偏差时，分别出现报警。

偏差=((当前值－目标值)÷(最大值－最小值))×100

由于偏差有正负，在偏差范围内相对目标值（基准值）上下波动的模拟量最小分界值称为最小当前值，相对目标值（基准值）上下波动的模拟量最大分界值称为最大当前值，则有：

最小当前值=目标值-(偏差/100)×(最大值－最小值)；

最大当前值=目标值+(偏差/100)×(最大值－最小值)； 例：某变量的最小值=－1000，最大值=1000，设定其小偏差=10，大偏差=15，目标值=500，则可计算出小偏差报警和大偏差报警的条件如下：

小偏差报警：

最小当前值=500－(10/100)×(1000－(－1000))=500－200=300

最大当前值=500+(10/100)×(1000－(－1000))=500+200=700

则：模拟变量值>=700或模拟变量值<=300时，出现小偏差报警；300<模拟变量值<700时，为正常工作范围

大偏差报警：

最小当前值=500－(15/100)×(1000－(－1000))=500－300=200

最大当前值=500+(15/100)×(1000－(－1000))=500+300=800

则：模拟变量值>=800或模拟变量值<=200时，出现大偏差报警；200<模拟变量值<800时，为正常工作范围。

返回

8、变化率报警代表什么意思、如何设置？

变化率：选择模拟量在给定时间内的变化率报警。每当变量发生变化时，就计算变化率以决定是否报警。若计算结果大于报警限值，则出现报警。时，分，秒按钮用于选择时间单位。单位的选择不影响检查变化率的时间，每次变量变化时，就计算变化率。变化率的计算公式如下：

变化率=((当前值－上一次值)/(最大值－最小值)/(当前时间－上一次值变化的时间))×100%。

返回

9、为什么有些打印机在打印实时报警时打出的为乱码？

为保证实时报警打印的实时性，系统将实时报警信息直接送到打印端口（如LPT1）输出打印，而不是调用WINDOWS系统的打印，因为在打印时要求有字库的支持，而直接送端口打印没有调用任何系统的东西，所以就要求打印机提供这些字库。如果没有字库，则打印出来的东西肯定为乱码。现在市场上的打印机除了部分针式打印机（如EPSON LQ1600K系列、LQ1900等）具有硬字库外，其余的打印机，所以打印出来的实时报警很容易出现乱码。

返回

10、为什么我在变量字典中定义了报警记录，但却找不到的报警记录的文件，记录到哪去了，需要进行那些设置？

历史报警生成的条件是：

(1) 在变量字典中，变量要选择“允许报警”选项，并且根据报警类型设置相关的报警参数。

(2) 在系统菜单“系统配置”--“报警配置”中，选中“记录到文件”，并且设置保存报警数据的路径，已经保存保存相关的参数。

返回

11、如何查询历史报警？

(1) 通过报警窗口过滤查询。在历史报警窗口中，用鼠标右键弹出菜单，选择“过滤”，设置查询参数。

(2) 通过函数：PrintHistAlarm() 实现。

(3) 运行系统配置时，在“定制菜单”中选择“文件”--“报表--”历史报警报表”，运行时，通过菜单调出历史报警报表对话框，设置查询参数。

返回

12、怎样产生声音报警？

通过命令语言实现，在发生报警时，调用PlaySound() 函数可以播放WAV声音文件；调用Voice()函数，可以将报警信息用标准普通话语音输出。

返回

13、系统中有很多报警，希望有一个变量报警就可以马上知道？

系统提供报警组变量，每个报警变量关联一个报警组变量，当报警组中任何一个变量发生报警时，报警组变量的域“.Alarm”将置1。

通过判断报警组变量的域就可以知道系统中是否有变量报警。

返回

14、如何知道系统中有未应答的变量？

系统提供报警组变量，每个报警变量关联一个报警组变量，当报警组中有一个变量没有应答时，报警组变量的域“.Ack”将置0。当报警组中所有的变量都应答后，报警组变量的域“.Ack”将置1。

通过判断报警组变量的域就可以知道系统中是否有未应答的报警变量。


历史曲线

  1. 如何保存历史数据？

  2. 定时记录与死区记录的区别？

  3. 历史数据记录配置中各个参数意义？

  4. 如何用一个历史趋势曲线在不同时刻根据要求显示不同变量的趋势曲线？

  5. 在历史趋势曲线中看不到曲线？

  6. 历史曲线是否可以进行曲线拟合操作？

  7. 历史趋势曲线最多能显示几条趋势曲线？

  8. 为什么运行时不能调出历史趋势曲线的配置对话框？

  9. 在历史趋势曲线中有多条曲线，只看一条曲线可以吗？

  10. 可以用按钮查询历史趋势曲线？

  11. 历史趋势曲线可以当实时曲线用吗？

  12. 历史趋势曲线中状态行按钮鼠标点击时会自动移动？

  13. 历史数据形成的文件是什么格式的呢？

1、如何保存历史数据？

保存历史数据条件：

(1) 设置每个变量数据记录的方式：变量字典中，需要保存的变量要选择“记录方式”，有两种记录方式：定时记录和死区记录，要保存历史数据必须选择其中一种记录方式。

(2) 配置真个系统历史数据记录：在菜单“系统配置”--“数据记录配置”中设置。

返回

2、定时记录与死区记录的区别？

(1) 定时记录：按照设定的时间，定时保存历史数据。一般不建议采用这种保存数据的方式，因为，这种方式不管数据是否变化，到时间就会记录，如果设置保存的时间很小，就会造成数据库变得很大，查询历史数据就会很慢。

(2) 死区记录：要设置一个死区值，相当于在当前值上下各画一条线，线到当前值的距离就是死区值，当数据变化达到或超出这个范围时，这个值才会记录下来。示例：变量的当前值是10，死区是1，则当变量的值大于9切小于11时，不记录；当变量的值为9或11时，变量的值才会记录到历史数据库中。

返回

3、历史数据记录配置中各个参数意义？

(1) 记录到文件：选中，则记录历史数据。

(2) 记录文件目录设置：选择历史数据保存的目录。提别提醒：“使用应用程序目录”仅用于演示工程或测试工程，使用到现场的工程，一定要选择“使用其他目录”！如果正式工程选择“使用应用程序目录”，所有的历史数据都会生成到用户工程所在的目录，这样，既不方便管理历史数据，又会影响整个系统的运行效率。

(3) 记录时间：每天需要记录数据的时间。

(4) 起始时间：每天记录数据的起始时间。

(5) 保存天数：历史数据在电脑中保存的天数。

示例：记录时间 = 8 小时、起始时间 = 8:00、保存天时 = 2天：每天从上午8:00点开始记录历史数据，记录8个小时，即到下午16:00点停止历史数据记录；历史数据库中只保存最近2天的数据，超出范围的历史数据，系统将自动删除。

实际应用中，一般设置：记录时间 = 24小时、起始时间 = 0:00、保存天时 = 30天，表示：每天从0:00点开始记录，记录时间是24小时；电脑中保存最近30天的历史数据。

返回

4、如何用一个历史趋势曲线在不同时刻根据要求显示不同变量的趋势曲线？

通过函数：HTSetPenName() 给趋势曲线的指定笔指定一个变量。

返回

5、在历史趋势曲线中看不到曲线？

(1) 变量字典中变量没有选择“数据记录方式”。

(2) 变量的量程过大，实际显示的数值占量程的百分比非常小，所以感觉没有曲线显示。

(3) 系统时间被修改，历史数据存储有误，所以曲线无法显示。

返回

6、历史曲线是否可以进行曲线拟合操作？

历史曲线中各个采集点的连接可以选择：矩形连接、直线连接和曲线连接，其中“曲线连接”就是曲线拟合后的曲线。

返回

7、历史趋势曲线最多能显示几条趋势曲线？

历史趋势曲线中最多可以同时显示32 条曲线。

返回

8、为什么运行时不能调出历史趋势曲线的配置对话框？

在开发系统中，用鼠标左键双击历史趋势曲线，弹出历史趋势曲线配置对话框，选中“显示配置对话框”，这样，在运行时，用鼠标左键双击曲线区域，就会弹出配置对话框。

返回

9、在历史趋势曲线中有多条曲线，只看一条曲线可以吗？

运行时，用鼠标左键双击历史趋势曲线的边框区域，在曲线的右边会显示列表框，其中，显示每天曲线对应游标处的值，游标对应的时间显示在右下角。

在曲线的右边会显示列表框中，每个变量的左边有个复选框，可以用鼠标左键选择，复选框选中变量曲线的就会显示，未选中的变量的曲线不会显示。

返回

10、可以用按钮查询历史趋势曲线？

函数中，以“HT”开始的函数为历史趋势曲线函数，通过这些函数可以控制历史曲线曲线的显示。

函数HTSetTimeParam()：设定历史趋势曲线的时间参数。通过这个函数可以用按钮查询历史趋势曲线。

返回

11、历史趋势曲线可以当实时曲线用吗？

函数中，以“HT”开始的函数为历史趋势曲线函数，通过这些函数可以控制历史曲线曲线的显示。

函数HTUpdateToCurrentTime ()：设置历史趋势曲线的终止时间为当前时间，曲线的时间长度保持不变。将这个函数写到画面命令语言(运行时)，历史趋势曲线可以当实时曲线用。

注释：历史趋势曲线当实时曲线用时，为避免影响系统的效率，请注意：

(1) 画面命令语言语言(运行时)的时间间隔最低设置成1秒，根据工程复杂程度，可以适当大些。

(2) 历史趋势曲线显示的时间长度要尽量短些，建议使用10分钟。

返回

12、历史趋势曲线中状态行按钮鼠标点击时会自动移动？

由于历史趋势曲线是调用磁盘上保存的历史数据，当历史趋势曲线显示的时间范围过大时,调用趋势曲线数据的时间会加长，如果连续调用历史数据，会造成系统堵塞，严重时，会因为系统资源占用太多引起系统崩溃。

因此，系统设定：当历史趋势曲线显示的时间范围超过1天时，为防止按钮连击，将鼠标限制到按钮之外的区域。历史数据调用结束后，系统自动解除鼠标移动的限制。

返回

13、历史数据形成的文件是什么格式的呢？

系统历史数据库是带压缩的二进制数据文件，只能在世纪星中打开，用户需要查看历史数据，只能借助软件的历史数据查询功能。

系统历史数据库是按天存储的，每天的历史数据包含两个文件，如2015年8月1日历史数据文件是：2015080100.IDX和2015080100.LGH，其中：*.IDX是历史数据索引文件；*.LGH是历史数据文件。


配方管理

  1. 什么是配方？

  2. 可以用EXCEL建立配方吗？

  3. 用户项目工程中包括多个不同的工艺，每个工艺中都需要配置大量的参数，请问有什么简单的方法实现？

  4. 运行时，可以查看配方吗？

  5. 运行时，如何直观地修改配方？

1、什么是配方？

配方就是为一组变量在不同的时刻成组赋值，就是说配方是设置变量值的一个集合，可以用来描述批处理过程中的不同步骤。

在工程配方中，有很多个配方，每个配方对应一组数据，配方功能就是按照工艺要求，调出相应的配方，将配方的数据付给对应的变量。

示例：水泥厂生产一、二、三、四号水泥，生产需要变量：水、石头、沙子，我们可以做四个配方，如下图所示：

(1) 生产一号水泥时，调用配方1，变量值：水=10、石头=15、沙子=20；

(2) 生产二号水泥时，调用配方2，变量值：水=18、石头=12、沙子=28；

(3) 生产三号水泥时，调用配方3，变量值：水=20、石头=15、沙子=25；

(4) 生产四号水泥时，调用配方4，变量值：水=15、石头=30、沙子=20。

返回

2、可以用EXCEL建立配方吗？

工程配方模板文件保存在用户工程目录下，文件格式是CSV文件格式，文件名称是配方名称，因此可以使用EXCEL编辑配方文件。

注释：

(1) 编辑配方表格时，配方中各项不能为空。

(2) 配方表格中，每个配方名称不能相同。

(3) 配方中输入的数据类型要与变量的数据类型相同。

返回

3、用户项目工程中包括多个不同的工艺，每个工艺中都需要配置大量的参数，请问有什么简单的方法实现？

可以通过配方功能实现，步骤如下：

(1) 创建工程配方，每个工艺对应一个配方，可以预先设置每个配方对应的数值。

(2) 在运行时，通过函数增加、减少或删除配方。

(3) 当用户需要切换工艺时，用配方函数调出相应的配方。

返回

4、运行时，可以查看配方吗？

配方功能中包含相应的函数，实现配方的特定功能。函数：RecipeBrowse(FileName) -- 调用“浏览配方”对话框，浏览指定工程配方模板文件中所有的配方。

返回

5、运行时，如何直观地修改配方？

通过配方函数：RecipeModify(FileName) -- 调用“修改配方”对话框，显示所有配方，在对话框中可以增加、修改或删除配方。


控件管理

  1. 支持自定义图形控件功能吗？

  2. 温控曲线如何只显示实时曲线？

  3. 如何利用多个摄像头在世纪星上显示多幅画面？

  4. 用世纪星做视频采集，该选用何种硬件？

  5. 世纪星怎样画两个变量的关系图？

  6. 如何将gif动画用在世纪星画面中？

  7. 如何利用多个摄像头在世纪星上显示多幅画面？

1、支持自定义图形控件功能吗？

系统提供自定义图形控件的功能，用户可以创建十种自定义图形控件，每种图形控件可以包含多个图形控件单元，每个图形控件单元包含动画连接。

返回

2、温控曲线如何只显示实时曲线？

温控曲线本是显示实际测试值按设定曲线变化的情况，必须存在设定曲线。但有些用户不需显示设定曲线，只需显示实际曲线，用户可将设定曲线的颜色设置为与背景色一样，这样看到的就只有采集的实际值曲线。

返回

3、如何利用多个摄像头在世纪星上显示多幅画面？

用户需要增加硬件设备：矩阵转换器和画面分割器。视频采集后通过矩阵转换和画面分割再送进世纪星中，例如需要显示16个画面，可选择16画面分割器。

返回

4、用世纪星做视频采集，该选用何种硬件？

需视频卡【建议使用天敏公司的产品】，摄像头，画面分割器（摄像头超过一台的话）。

返回

5、世纪星怎样画两个变量的关系图？

用X-Y曲线控件可以表现出两个变量的关系图。

返回

6、如何将gif动画用在世纪星画面中？

系统提供“GIF动画”控件，可以直接加载GIF动画文件。

返回

7、如何利用多个摄像头在世纪星上显示多幅画面？

系统提供“视频控件”，根据视频卡选择相应的设备，这样在画面上就可以显示视频图像，如果视频卡具有多屏功能，就可以在“视频控件”上显示多个摄像头画面。


联网运行

  1. 联网运行中，“使用从网卡”有什么用途？

  2. 联网运行中，如何选择服务器和客户端电脑？

  3. 联网运行时，客户端刷新数据过慢，如何解决？

  4. 如何判断双极热备的设备那一台在工作？

  5. 四台电脑可以同时控制一台PLC设备吗？

1、联网运行中，“使用从网卡”有什么用途？

系统联网运行时，支持双网络冗余功能，即：两台电脑之间有两个网络连接，当一个网络连接失败时，系统会自动使用另外一个网络进行连接。两个网络中，一个网络为主网络，另一个网络为从网络。

返回

2、联网运行中，如何选择服务器和客户端电脑？

系统联网运行采用C/S模式，由客户端查询服务器的数据。

示例：现场两台电脑分别为电脑A和电脑B，电脑A从下位机采集数据，电脑B是操作员站。设置方法如下：

(1) 选择电脑A作为服务器，电脑B为客户端。

(2) 电脑A在网络配置中，配置“联网运行”。

(3) 电脑B在网络配置中，配置“联网运行”。

(4) 电脑B在驱动设备管理中创建“网络”设备，远程机器名为电脑A的机器名或IP地址。

(5) 电脑B的变量字典中，创建IO变量，变量的类型与电脑A中的变量类型相同，远程变量名为电脑A中的变量名称。

返回

3、联网运行时，客户端刷新数据过慢，如何解决？

在客户端修改相关参数：

(1) 在“运行系统配置”--“系统配置”中，设置“基准时间”小一些。

(2) 在“网络系统配置”--“参数配置”中，设置“查询频率”小一些。

返回

4、如何判断双极热备的设备那一台在工作？

通过系统变量 $双机热备的值判断：

(1) $双机热备=-1：主站工作异常。

(2) $双机热备=1：主站工作正常。

(3) $双机热备=100：主站工作正常，从站通过网络从主站采集数据。

(4) $双机热备=-100：主站工作异常，从站直接采集下位设备数据。

返回

5、四台电脑可以同时控制一台PLC设备吗？

可以，采用双机热备和联网运行方式即可以，实现方法如下：

(1) 两台电脑采用双机热备方式运行，一台作为主机，一台作为从机。将PLC设备连接到这两台电脑上。

(2) 两外两台电脑采用联网运行的方式，每台电脑建立一个网络设备，网络设备中，远程机器名设置为主机的IP地址，备用IP地址设置为从机的IP地址。

这样，四台电脑可以同时读取PLC的数据，也可以同时控制PLC运行。

注释：采用这个方法，可以用多台电脑控制一台PLC设备。


WEB发布

  1. 什么是WEB发布？

  2. 如何成功实现WEB发布？

  3. 为什么WEB发布正常，客户端浏览器看不到？

  4. WEB客户端可以往设备写数据吗？

  5. IE8、IE10可以当作WEB客户端浏览器吗？

1、什么是WEB发布？

WEB 发布是本系统在广域网(Internet)上发布图形和数据，即数据远程浏览功能。同基于局域网络的网络版相比，WEB 发布功能采用了国际上最先进的数据传输体系结构，确保数据传输精确、实时。用户在 Internet 网上，通过 IE 浏览器，输入服务器的 IP 地址，就可以查看现场的画面和数据。

系统的 WEB 发布基于客户机/服务器（B/S）结构，由 WEB 浏览器(客户机)和 WEB 服务器(服务器)构成，两者之间采用 TCP/IP 传送协议进行通信。

返回

2、如何成功实现WEB发布？

WEB 发布步骤如下：

(1) 确定需要发布的变量：在变量字典中，每个变量都具有选项“WEB 发布”，选中该选项，则该变量的数据变化可以在远程浏览。

(2) WEB 发布组设定：在“运行系统配置”对话框中选择“WEB发布组”，配置需要发布的画面窗口。

(3) 配置 WEB 发布网络：在“系统配置”的“网络配置”中，“本机运行模式”选择“WEB 发布”。

(4) WEB 发布：在“浏览器”中双击“WEB 发布”,或在“系统”菜单中，选择“WEB 发布”。

返回

3、为什么WEB发布正常，客户端浏览器看不到？

WEB发布时，注意事项：

(1) 变量字典中，只有选择“WEB 发布”的变量，在远程客户端才能浏览或修改。

(2) 控制画面切换的变量，不能选择“WEB 发布”，否则在远程无法切换画面。

(3) WEB 发布组的名称只能是英文字符，组注释可以是中文或英文字符。

(4) 当 HTTP 服务器端口号为 80 时，IE 地址为：192.168.1.111；当 HTTP 服务器端口号为 80 之外的端口时（如：81 端口），IE 地址为：http://192.168.1.111:81/index.html。

(5) WEB 发布的计算机有防火墙或防病毒软件时，应询问专业网络工程师设置防火墙或防病毒软件，测试阶段可以关闭防火墙或防病毒软件。

(6) WEB 发布时，远程客户端不运行“应用程序命令语言”、“事件命令语言”、“数据改变命令语言”、“热键命令语言”。如果需要在远程客户端运行命令语言，可以在“WEB 命令语言”中编制。“WEB 命令语言”仅在远程客户端运行，不在发布的计算机（即：服务器端）运行。

(7) 普通用户--可以浏览画面；高级用户--可以浏览画面，并且能远程修改变量。高级用户必须设置用户登录，WEB 用户登录用于验证用户登录到“WEB 发布组”，与系统的用户登录没有关系。

(8) 软件升级时，在浏览客户端需要删除已经加载控件(升级时删除一次就可以了)，再安装客户端浏览软件(即：运行 WebSetup.exe 或网上直接安装)。

注释：浏览客户端中删除已经加载的 WEB 控件的方法有两种：

(1) 在 C:\WINDOWS\Downloaded Program Files 目录中直接删除已经加载的 WEB 发布控件；

(2) 点击 IE 浏览器，按右键选择“属性”菜单，弹出“Internet 属性”对话框，选择“常规”属性页，在“浏览历史记录”中按“设置”按钮，弹出“Internet 临时文件和历史记录设置”对话框，选择“查看对象”按钮，可以看到已经加载的控件，删除其中的控件。

返回

4、WEB客户端可以往设备写数据吗？

WEB 客户端浏览器可以往WEB服务器写数据，如果是IO变量，则数据可以直接写入到相关的设备中，主要有两点要注意：

(1) WEB 发布组设定：在“运行系统配置”对话框中选择“WEB发布组”，配置需要发布的画面窗口，选中“需要登录”选项，配置“高级用户”。

(2) 在客户端浏览时，需要用“高级用户”登录。

返回

5、IE8、IE10可以当作WEB客户端浏览器吗？

WEB发布对客户端浏览器没有要求，目前操作系统支持的浏览器都可以使用，如果不能使用，肯定是浏览器的设置有问题，用户可以针对使用的浏览器，在网上查询该浏览器的使用方法。查询关键词：浏览器安全设置、控件下载、控件运行。


报表打印

  1. 世纪星有哪些报表打印方式？

  2. 如何实现历史报表的定时打印？

  3. 如何用历史报表实现数据统计？

  4. 组态报表是否可以打印柱形图、折线图、散点图、饼图？

  5. 组态报表中如何调出函数公式？

  6. 组态报表是否可以生成日报表、月报表、年报表？

  7. 我要查询某一时间段的报表，如何实现？

  8. EXCEL格式文件能否打印？

  9. 系统支持数据库表格打印吗？

  10. 组态报表打印时，数据小数点的位数不够，怎么办？

  11. 如何修改报表的尾注标识？

  12. 是否可以生成事件报表？

  13. 如何利用报表来实现数据统计？

  14. 如何打印信息到针式打印机？

1、世纪星有哪些报表打印方式？

系统提供丰富的画面打印及报表打印功能，具体如下：

(1) 打印屏幕：打印整个电脑屏幕画面，函数：PrintScreen()。

(2) 画面图形打印：打印指定窗口画面或画面中指定矩形区域，函数： PrintWindow()。

(3) 实时数据报表打印：调出“实时数据报表”对话框，打印实时数据报表。

(4) 实时报警数据报表打印：调出“实时报警数据报表”对话框，打印实时报警数据报表。函数：PrintRealAlarm()。

(5) 历史报警数据报表打印：调出“历史报警数据报表”对话框，打印实时历史数据报表。函数：PrintHistAlarm()。

(6) 历史数据报表打印：调出“历史数据报表”对话框，可以查询打印8个变量的历史数据报表。函数：PrintHistData8()。

(7) 历史曲线报表打印：调出“历史数据报表”对话框，查询打印8个变量的历史曲线。函数：PrintHistData8()。

(8) 事件查询报表打印：调出“事件查询报表”对话框，打印事件报表。函数：PrintEventsQueryForm()。

(9) 组态报表：系统提供特有的组态报表，开发人员可在开发系统中的组态报表模板中建立模板，在运行系统中，调用组态报表模板以生成组态报表，用于打印和浏览组态报表。函数：PrintFormTable()。

(10) 其它报表：系统提供组态报表，根据现场工艺要求，制作日报表模板、月报表模板、年报表模板，运行时，可以通过函数直接打印报表，也可以通过表格框控件，在画面上将表格显示出来，选择打印。

返回

2、如何实现历史报表的定时打印？

通过“事件命令语言”实现定时打印。在事件命令语言中，用时间作为事件，当事件发生时，调用函数实现定时打印。

示例：每天上午8:00打印一次，则事件命令语言的“事件描述”：

($时==8)&&($分==0)&&($秒==0)

命令语言中调用打印函数：PrintHistData8()、PrintFormTable()。

返回

3、如何用历史报表实现数据统计？

组态报表提供大量的计算和统计函数，在“组态报表”的报表模版中，使用统计函数，实现数据统计功能。

返回

4、组态报表是否可以打印柱形图、折线图、散点图、饼图？

组态报表提供各种常见图表，在“组态报表”的报表模版中，可以绘制柱形图、折线图、散点图、饼图，可以同相关表格数据建立联系。

返回

5、组态报表中如何调出函数公式？

组态报表支持常见公式运算，在“组态报表”的报表模版中，选中单元表格，按“=”键，即可弹出所有函数、公式。

返回

6、组态报表是否可以生成日报表、月报表、年报表？

在组态报表中，制作日报表模板、月报表模板、年报表模板，运行时，通过函数调用，系统可以自动生成：日报表、月报表、年报表。

返回

7、我要查询某一时间段的报表，如何实现？

查询某一时间段的历史数据，可以采用以下两种方式：

(1) 使用“历史数据报表打印”功能：用函数PrintHistData8() 调出历史数据报表打印对话框，设置查询参数。用此函数也可以不弹出对话框，直接打印报表。

(2) 使用“组态报表”功能：制作需要的报表模板，用函数PrintFormTable()实现查询报表打印。

返回

8、EXCEL格式文件能否打印？

组态报表模板支持CSV格式文件和XLS格式文件打印。

返回

9、系统支持数据库表格打印吗？

系统提供数据库表格框控件，只需要输入数据源、用户名和密码，就可以浏览数据库表格，还可以打印报表。

返回

10、组态报表打印时，数据小数点的位数不够，怎么办？

组态报表模板的编辑功能，可以设置数据显示的字体、数据显示格式等，如果打印时数据小数点的位数不够，就需要编辑对应的报表模板，调整数据显示格式。

返回

11、如何修改报表的尾注标识？

打印报表功能可以设置尾注标识，用于显示用户单位或项目信息，这些信息是可以修改的，并具有记忆功能。

返回

12、是否可以生成事件报表？

在“系统配置-事件记录配置”中设置事件，当事件发生时，就会产生事件记录，在运行系统中，可以查询这些报表。

返回

13、如何利用报表来实现数据统计？

可以通过标准数据库和组态报表配合实现：

(1) 设计一个源报表，该报表中存储各种用于数据统计分析的源数据，可以在系统运行时，将源数据添到报表中， 需要统计分析时，可以取出数据进行统计分析。然后将结果添加到统计结果报表中。

(2) 通过数据库与报表结合的方式。将所需的数据通过的SQL功能记录到数据库中，当需要统计分析时，可以通过条件查询，将查询到的数据添加到源报表中，然后通过对源报表的计算将统计结果输出到正式报表中。

返回

14、如何打印信息到针式打印机？

系统提供实时按行打印功能，用于打印实时信息，实时打印函数：

语法：PrintRealMessage( PortNo, "CommandCode", Message);

参数：PortNo -- 端口号

CommandCode -- 打印机控制代码,十进制,逗号分割, "EPSON1600, 27, 64, 3, 30"

Message -- 打印信息，字符串或信息变量

返 回: 0 -- 打印正常；1 -- 打印机初始化错误；2 -- 打印机端口错误；3 -- 打印机超时。

注释：可根据需要在按钮或其他命令语言中用此函数时，实现按行打印字符串信息。


ODBC功能

  1. 什么是ODBC？

  2. SQL管理是什么？

  3. SQL函数怎么使用？

  4. 能自动创建数据源吗？

  5. 数据库字段为"反应罐#温度"时, 无法通过ODBC往数据库中写数据？

  6. 世纪星ODBC功能支持存储过程吗？

  7. 实数类型存入数据库后为什么在世纪星中无法读取？

  8. 世纪星与MIS系统如何进行数据交换？

  9. 数据库插入记录失败？

  10. 为什么连接句柄会显示1000？

1、什么是ODBC？

开放数据库互连（Open Database Connectivity，ODBC）是微软公司开放服务结构（WOSA，Windows Open Services Architecture）中有关数据库的一个组成部分，它建立了一组规范，并提供了一组对数据库访问的标准API（应用程序编程接口）。

世纪星软件支持ODBC功能，即：标准数据库访问(SQL)功能，是实现系统与标准数据库之间数据交换，包括：SQL 管理、SQL 函数、执行标准 SQL 语句的函数、报警数据和历史数据直接记录到标准数据库、数据库表格控件。

返回

2、SQL管理是什么？

SQL 管理用来建立标准数据库和系统中变量之间的联系，SQL管理包括：

(1) 表格模板管理：表格模板用于定义在标准数据库中创建表格的字段，用户创建表格模板，然后以这种模板在数据库中添加表格，表格模板信息存储在SQL.DEF文件中。

(2) 记录列表管理：记录列表用来连接表格的列和变量数据库中的变量，即将数据库表中的字段与世纪星的变量[或变量.域]绑定，记录列表信息存储在 BNID.DEF 文件中。

返回

3、SQL函数怎么使用？

系统的ODBC功能是通过SQL函数实现的，通过SQL函数实现：创建数据源、打开数据库、写数据库记录、修改数据库记录、删除数据库记录、查询数据库、关闭数据库等功能。

返回

4、能自动创建数据源吗？

通过SQL函数：SQLAutoConfigDSN() 实现。创建数据源函数只需要执行一次就可以了，因为，一般放置到“应用程序命令语言(启动时)”中。

示例：创建Access数据源：“数据源1”, 数据库文件位于工程目录下：Database.mdb，则创建数据源函数如下：

Result=SQLAutoConfigDSN( "Microsoft Access Driver (*.mdb)", "数据源1", "", "", InfoAppDir( )+"Database.mdb", 1 );

其中：函数InfoAppDir( ) 用于获取用户工程项目的路径。

返回

5、数据库字段为"反应罐#温度"时, 无法通过ODBC往数据库中写数据？

标准数据库中有很多关键词和符号，这些关键词和符号是不能用作字段名称的。

返回

6、世纪星ODBC功能支持存储过程吗？

标准数据库中存储过程是通过SQL函数实现的，世纪星的SQL函数支持存储过程。在“在线帮助”的“标准数据库访问(SQL功能)”中“SQL执行存储过程”有详细的示例。

返回

7、实数类型存入数据库后为什么在世纪星中无法读取？

原因是因为客户在数据库中定义的字段的类型不对。在世纪星中定义的内存实型变量，在ACCESS数据库中对应的字段的类型应该是单精度型，在SQL SERVER数据库中对应的字段的类型应该是real型.(不能为float型)。

返回

8、世纪星与MIS系统如何进行数据交换？

通过标准数据库实现数据交换：

(1) 世纪星通过SQL函数实现与标准数据库进行数据交换。

(2) MIS系统与标准数据库进行数据交换。

返回

9、数据库插入记录失败？

(1) 在信息窗中查看数据库是否连接；

(2) 数据库表格的字段名与世纪星记录体定义的字段名是否相同；

(3) 数据库表格的字段类型与世纪星变量的类型是否符合，推荐使用世纪星的表格模板创建表格；

(4) 表格中使用的字段名是否为data和time，这些是数据库的关键字，需要更改为其他字段。名。

返回

10、为什么连接句柄会显示1000？

SQL函数：SQLConnect()正确执行后会返回连接句柄，这是一个很大的整数，如果返回1000，则说明在创建连接句柄变量时，最大值设置为1000了，当返回值大于1000时，被系统强制到最大值。

解决这个问题很简单，只需要将连接句柄的最大值设置成一个很大的数就可以了。如果连接句柄显示的值等于变量字典中连接句柄的最大值，则说明连接句柄的最大值不够大。


设备驱动

  1. 世纪星的驱动帮助在哪里？如何查看？

  2. 世纪星与现场设备之间有几种连接方式？

  3. 网络设备对象的远程变量名是什么意思？

  4. DDE设备对象的项目名是什么意思？

  5. 如何查看世纪星与下位机设备的通讯状态？

  6. 如果您自己开发的设备支持MODBUS协议，但在系统中没有您需要的设备驱动，怎么办？

  7. 不同协议的硬件设备挂在同一个485网下对通讯是否有影响？

  8. 世纪星和其他应用程序的接口？

  9. 世纪星可以当作MODBUS从站？

  10. 世纪星支持Modem通讯吗？

  11. 世纪星和单片机怎么通讯？

  12. 在使用串口设备通讯时应注意哪些问题？

  13. 世纪星可以直接操作并口、串口、I/O地址？

  14. 使用板卡采集数据时应注意什么？

  15. 世纪星支持WIN2000、NT下的板卡采集吗，需要特殊设置吗?

  16. 世纪星软件与设备的通讯与距离有关吗？

  17. 世纪星支持的串口最多为多少？

  18. 工程运行时，显示“设备对象不存在”,怎么办？

  19. 如何添加新驱动？如何注册驱动程序？

  20. 如何提高设备通信速度？或设备通信速度慢怎么办？

  21. 通信失败后，如何快速恢复通信？

  22. 世纪星组态软件支持 OPC Server 吗？

  23. 世纪星组态软件支持远程 OPC Server 吗？如何读取远程 OPC Server 的数据？

  24. IOServer驱动与老驱动可以同时使用吗？如何使用IOServer？

1、世纪星的驱动帮助在哪里？如何查看？

（1）世纪星开发系统中，在“帮助”菜单中，选择“驱动设备帮助”。

（2）世纪星开发系统中，按键盘 F1 键，弹出“世纪星帮助”，在帮助窗口左边的目录中，选择最下面的“调用驱动设备帮助（CSDriver.chm）,在“驱动设备帮助”页面中，点击“驱动设备帮助：CSDriver.chm”。

（3）在硬盘上找到世纪星的系统目录(缺省：C:\CenturyStar)，在目录中查找文件：CSDriver.chm，用鼠标左键双击执行驱动设备帮助文件：CSDriver.chm

返回

2、世纪星与现场设备之间有几种连接方式？

世纪星与设备之间的驱动方式如下：

(1) 板卡设备：板卡插在计算里面的扩展槽中。有两种驱动方式：一是直接读写板卡的IO地址；二是调用厂家提供动态连接库(DLL)读写数据。

(2) 串口设备：连接到计算机的串口或串口扩展卡扩展出的串口上。如果计算机是RS232接口，设备是RS485/422接口，则需要通过RS232/RS485/RS422转换器转换，串口设备包括PLC、变频器、仪表、模块等。

(3) 网络设备：连接到计算机的网络端口上。网络设备包括PLC、变频器、仪表、模块等。

返回

3、网络设备对象的远程变量名是什么意思？

需要采集的变量在远程计算机中，相对应的变量名称。

返回

4、DDE设备对象的项目名是什么意思？

世纪星采用 DDE 协议进行数据交换时，服务应用程序名：CSVIEWER，话题名：TAGNAME，项目名：变量字典中变量所对应的项目名称。 示例：将世纪星作为服务器，EXCEL 作为客户程序，EXCEL 要从世纪星取得数据，则可在 EXCEL 的某单元格中规定：

＝CSVIEWER|TAGNAME!ITEM

其中CSVIEWER 是服务应用程序名，TAGNAME 是话题名，ITEM 是变量的项目名，当系统中该变量发生变化时，EXCEL中相应的单元格的数据就会改变。

返回

5、如何查看世纪星与下位机设备的通讯状态？

I/O变量用一个域：.CommStatus 表示通信状态: 0 -- 通讯正常; -1-- 通信错误。

返回

6、如果您自己开发的设备支持MODBUS协议，但在系统中没有您需要的设备驱动，怎么办？

系统提供了标准的MODBUS协议设备，可以用于任何一种支持标准MODBUS协议的设备，也可以用莫迪康PLC下的MODBUS协议。需要注意的是MODBUS的内存映射地址。

返回

7、不同协议的硬件设备挂在同一个485网下对通讯是否有影响？

一般情况下，不建议这样使用，因为，一台设备的驱动协议中，可能有一部分数据满足另外一台设备的驱动协议，这样会造成数据采集或控制出现错误。

返回

8、世纪星和其他应用程序的接口？

（1）系统与第三方软件交互的接口主要是通过数据交换标准控件 DBComm.ocx 和 AlarmComm.ocx 来实现的，请查看世纪星在线帮助中“数据接口标准控件(DBComm、AlarmComm)”。

（2）DBComm 和 AlarmComm 数据交换标准控件的示例源程序和示例工程，见：硬盘上世纪星的系统目录（缺省：CenturyStar）中 InterFace 目录。

注释：如何数据交换标准控件 DBComm 和 AlarmComm 加载失败，请注册世纪星的系统目录（缺省：CenturyStar）中 DBComm.ocx 和 AlarmComm.ocx 文件。

返回

9、世纪星可以当作MODBUS从站？

系统与外设通讯时，支持 MODBUS 主站和从站通讯，只需要在创建设备时，选择相应的驱动程序即可。

返回

10、世纪星支持Modem通讯吗？

系统支持Modem通讯，具体跟所驱动的设备相关。

返回

11、世纪星和单片机怎么通讯？

系统提供一个通用单片机驱动协议，单片机只要按该协议编制通讯程序即可。

返回

12、在使用串口设备通讯时应注意哪些问题？

(1) 串口的通讯超时，为系统向设备发送命令最长等待响应的时间，当超过这个时间设备不响应，系统判断设备故障，或不存在。

(2) 系统配置中的数据采样间隔，为同个设备两个周期的采样的间隔

(3) 变量字典中的采集频率，选择从设备对象中采集数据的频率。

(4) 对通过串行口通讯的设备应注意通讯电缆是否正确、串口的波特率、数据位、停止位、奇偶校验位是否和硬件设备一致、硬件设备是否支持通讯功能、通讯方式是232、485、422、最好是用厂家提供的测试程序先测试硬件是否通讯正常，同时请细心阅读关于该硬件驱动的帮助。

返回

13、世纪星可以直接操作并口、串口、I/O地址？

可以，请参看IO_、Port_开头的函数。

返回

14、使用板卡采集数据时应注意什么？

(1) 先查看板卡的产品说明书,了解并设置板卡的地址;了解并设置板卡的接线方式;了解板卡是否需要进行跳线,如果板卡需要跳线请设置合适跳线；最后将板卡安装到计算机上。

(2) 板卡安装完毕后,使用厂家提供的测试程序先测试板卡是否工作正常?如果工作不正常请查看板卡的地址，跳线是否正确，连线是否正确，以及信号输入是否正确。具体请参看板卡的产品说明书。

(3) 测试正常后，就可以在世纪星中新建该设备，然后新建变量；同时请细心阅读关于该硬件驱动的帮助。

(4) 新建变量时请注意以下几个问题：

● 新建变量时，通道号是从0开始，也就是第一个通道为0通道。

● 新建模拟量输入变量（AD变量）时，在变量数据库中设置变量的最大值，最小值，最大值[IO]，最小值[IO]要注意了。变量的最大值和最小值是在世纪星中使用的变量值的范围，而变量的最大值[IO]和最小值[IO]是世纪星从硬件中获得的值的范围。

返回

15、世纪星支持WIN2000、NT下的板卡采集吗，需要特殊设置吗?

板卡的驱动程序有生产板卡的厂家确定，只要厂家的板卡支持的操作系统，我们都支持。

返回

16、世纪星与设备的通讯与距离有关吗？

上下位机通讯所用到的如232串口、485总线、工业以太网、局域网、电台等，这些都受距离限制，但此限制是受现场和硬件设备所左右，与世纪星软件功能无关。

返回

17、世纪星支持的串口最多为多少？

支持的串口最多可扩展到256个串口，且每个串口最多可接设备数量由硬件厂家决定。

返回

18、工程运行时，显示“设备对象不存在”,怎么办？

(1) 缺少设备驱动程序。向厂家索取相应的设备驱动程序。

(2) 设备驱动程序没有注册：在系统目录(缺省：C:\CenturyStar)中执行 Register.exe (文件图标为一个红色的大写的 R )，弹出注册对话框，“文件类型”选择“DLL files(*.dll)”,文件选择：系统目录下的 Driver 目录(缺省：C:\CenturyStar\Driver)中刚复制的文件，如标准MODBUS驱动程序文件：C:\CenturyStar\Driver\ModbusPro.dll。

返回

19、如何添加新驱动？如何注册驱动程序？

新开发的设备驱动程序包括两个文件：Device.idx 和 *.dll，其中，Device.idx是驱动程序的索引文件，*.dll 是设备驱动程序。

当你收到世纪长秋公司发来的上述两个文件时，应做以下工作：

(1) 将 Device.idx 拷贝到系统目录(缺省：C:\CenturyStar)中；将 *.dll 文件拷贝到系统目录下的 Driver 目录(缺省：C:\CenturyStar\Driver)中。

(2) 驱动注册：在系统目录(缺省：C:\CenturyStar)中执行 Register.exe (文件图标为一个红色的大写的 R )，弹出注册对话框，“文件类型”选择“DLL files(*.dll)”,文件选择：系统目录下的 Driver 目录(缺省：C:\CenturyStar\Driver)中刚复制的文件，如标准MODBUS驱动程序文件：C:\CenturyStar\Driver\ModbusPro.dll。

注释：Win7、Win8系统中，运行 Register.exe 程序时，需要先选中 Register.exe ，再按右键弹出菜单，选择“以管理员身份运行”。

返回

20、如何提高设备通信速度？或设备通信速度慢怎么办？

1、在“系统配置”--“运行系统配置”对话框中，调整“基准时间”的值。基准时间是画面刷新的频率，如设置基准时间为100毫秒，则画面每分钟刷新10次，从这个意义上讲，基准时间是越小越好，但是，计算机是个分时运行的系统，如果画面刷新占用的时间多了，就会占用其他部分如数据采集等的时间，严重时会停止数据采集，因此，要根据工程的实际情况决定基准时间的大小。

2、在“变量数据库”对话框中，IO变量具有“采集频率”参数，调整“采集频率”可以提高通信速度，对于一些不常用的数据采集，如：设备配置参数等，可以将“采集频率”的值设置大一些。

3、对于能够成组读取数据的设备，如：Modbus 协议设备，将寄存器类型相同尽量集中，系统可以一次读取多个数据。

返回

21、通信失败后，如何快速恢复通信？

在“驱动设备管理”中，双击驱动设备对象，弹出驱动设备参数修改对话框，其中：“尝试恢复间隔”参数，就是在通信失败后，多长时间开始尝试与设备通信。

1、修改“尝试恢复间隔”时间，可以快速恢复通信。

2、对于偶尔通信中断的设备，在“系统配置”--“运行系统配置”--“其它参数”对话框中，参数：“通信设备失败时数据显示方式”选择“保持原值”。

返回

22、世纪星组态软件支持 OPC Server 吗？

支持。世纪星组态软件可以作为 OPC Client 读取第三方软件的 OPC Server 的数据，也可以作为 OPC Server 为第三方软件提供数据。

注释：世纪星组态软件作为 OPC Server 时，需要注册世纪星系统目录（缺省：C:\CenturyStar）中的 OPCServer.reg 文件，用鼠标左键双击 OPCServer.reg 文件即可注册。

返回

23、世纪星组态软件支持远程 OPC Server 吗？如何读取远程 OPC Server 的数据？

世纪星组态软件支持远程 OPC Server，但是需要配置 DCOM 程序，DCOM 是 Windows 系统自带的配置程序，每个 Windows 版本的配置方法有些区别，建议在网上搜索“DCOM配置”，找到相应 Windows 版本下的 DCOM 配置方法。

世纪星作为 OPC Client 读取远程 OPC Server 数据的方法，建议如下：

(1) 将第三方 OPC Server 安装到本机上。

(2) 在世纪星中创建 OPC 设备，读取本地 OPC Server 的数据。

(3) 在世纪星创建的 OPC 设备中，增加远程机器的 IP 地址，读取远程 OPC Server 的数据。

返回

24、IOServer驱动与老驱动可以同时使用吗？如何使用IOServer？

系统可以同时使用老驱动和 IOServer 驱动，但是要注意通信端口不能冲突。

IOServer 使用方法如下：

(1) 开发系统中--在屏幕左边浏览器中--驱动设备--调用通信工具 CommTool，打开 IOServer 的配置工具。

(2) 或在世纪星的系统目录（缺省：C:\CenturyStar）中，找到 CommTool.exe 文件，用鼠标左键双击运行。

(3) 在 CommTool 中，按键盘 F1 键，弹出帮助文档。

(4) 在帮助文档中，查看：IO 驱动使用入门。

(5) 在世纪星的系统目录（缺省：C:\CenturyStar）中，有完整的帮助文档：IO驱动使用说明.DOC。


安全与权限

  1. 世纪星的安全策略是什么？

  2. 什么是访问权限和安全区？在什么地方使用?

  3. 世纪星的访问权限如何确定？

  4. 访问权限和安全区的使用方法？

  5. 系统管理员密码是多少，能修改吗？

  6. 忘记了超级用户的密码怎么办？

  7. 如何配置用户，有什么需要注意的地方,在系统中怎么用？

  8. 如何在线增删用户及用户密码和权限？

  9. 可以自定义登录画面窗口吗？

1、世纪星的安全策略是什么？

世纪星的安全策咯：系统提供访问权限和安全区的双重保护策略。

当控制系统中包含多个控制过程，同时又有多个操作人员操作该控制系统时，为了安全地管理控制系统中的不同控制过程，系统为每个控制过程设置了安全区，在每个安全区内，对控制过程的有关操作流程设置了访问权限，同时给每个操作人员也设置了相应的安全区和访问权限。当操作人员的操作安全区在控制过程的安全区内，并且操作人员的访问权限大于或等于控制过程中相关操作的访问权限时，操作人员才能执行相应的操作。

返回

2、什么是访问权限和安全区？在什么地方使用?

访问权限：操作人员操作图形对象、热键命令语言、控件时所具有的权限，系统为图形对象、热键命令语言、控件及操作人员均设置了访问权限，访问权限范围为：0 - 9999。

安全区：操作人员操作图形对象、热键命令语言、控件时所在的区域，系统为图形对象、热键命令语言、控件及操作人员均设置了安全区，安全区最多可以设置 32 个。

访问权限和安全区使用范围：

(1) 用户输入连接：离散值输入、模拟值输入、信息输入。

(2) 滑动杆输入连接：水平滑动杆输入、垂直滑动杆输入。

(3) 按钮离散值连接。

(4) 按钮命令语言连接。

(5) 可以操作的图形控件。

返回

3、世纪星的访问权限如何确定？

访问权限为0-9999之间的一个整数。访问权限数值越大，权限级别越高。

系统为用户设置了两个缺省用户：

(1) 用户名：系统管理员；密码：(缺省为空，即没有密码)；访问级别：9999；安全区：所有区域。

(2) 用户名：NONE；密码：无；访问级别：0，安全区：无。

系统规定：

(1) 只有访问级别大于9000的用户才能配置用户。

(2) 只有访问级别大于9000的用户才能执行具有系统安全设置的功能。

(3) 只有“超级用户”才能修改“超级用户”的名称和密码。

(4) 密码区分大小写。

返回

4、访问权限和安全区的使用方法？

访问权限和安全区使用示例：某化工厂中，有三台设备：A设备、B设备和C设备；操作人员：工人A和工人B。访问权限和安全区设置如下图所示：

“工人A”和“工人B”的访问权限一样，均为1000；由于他们的安全区域不同，“工人A”只能操作“A设备”和“C设备”的对象和数据，“工人B”只能操作“B设备”和“C设备”的对象和数据。

返回

5、系统管理员密码是多少，能修改吗？

世纪星系统管理员的缺省密码为空，用户可以随时修改系统管理员密码。

返回

6、忘记了超级用户的密码怎么办？

(1) 关闭开发系统和运行系统。

(2) 删除用户工程目录下的文件：CSUsers.dat，重新配置用户即可。

返回

7、如何配置用户，有什么需要注意的地方,在系统中怎么用？

在开发系统和运行系统中均可以配置用户，只要登录用户的访问级别在9000以上即可。

返回

8、如何在线增删用户及用户密码和权限？

当登录用户的访问权限大于9000时，可以用ConfigUsers() 函数实现。

返回

9、可以自定义登录画面窗口吗？

用户可以自行设计登录画面，通过函数 LogOnEx() 返回登录用户的访问级别。


运行系统

  1. 如何改变应用程序的标题？

  2. 什么是基准时间？如何设置？

  3. 运行系统中的数据采样间隔各是什么意思？

  4. 运行系统中闪烁频率的慢速、中速、快速各是什么意思，如何设置？

  5. 如何禁止任务栏切换？

  6. 如何避免运行系统启动后，用户随便退出运行系统？

  7. 如何在运行系统启动时，显示指定画面？

  8. 运行系统配置的定制菜单做什么用？

  9. 运行系统配置中的通讯失败数据显示如何设置，各代表什么意思？

  10. 如何运行用户工程项目？

  11. 世纪星能否在运行状态下切换到另一个工程？

  12. 如何在打开机器时自动进入运行环境？

  13. 如何设置开机时自动启动世纪星软件？

  14. 如何修改电脑的时间？

  15. 如何多屏显示？如何快速定位画面到各个屏幕中？

  16. 世纪星可以实现仿真功能，就是可以当作仿真软件来用？

  17. 开发时，文本在矩形后面，运行时，文本却在矩形前面，为什么？

1、如何改变应用程序的标题？

在菜单“系统”--“系统配置”--“运行系统配置”的“系统配置”中设置，改变“标题”的内容，就改变了应用程序的标题。

返回

2、什么是基准时间？如何设置？

保存历史数据条件：

(1) 基准时间：系统运行时的最小时间间隔。所有的动画连接、脚本运行的时间间隔都必须是这个基准时间的整数倍。

(2) 基准时间的设置：在菜单“系统配置”--“运行系统配置”中设置

(3) 基准时间是画面刷新的频率，如设置基准时间为100毫秒，则画面每分钟刷新10次，从这个意义上讲，基准时间是越小越好，但是，计算机是个分时运行的系统，如果画面刷新占用的时间多了，就会占用其他部分如数据采集等的时间，严重时会停止数据采集，因此，要根据工程的实际情况决定基准时间的大小。

(4) 基准时间的缺省设置：500毫秒。可以根据工程项目灵活设置，原则是：在保证数据采集快速、准确的情况下，基准时间可以适当减小，增强画面的动画效果。

返回

3、运行系统中的数据采样间隔各是什么意思？

数据采样间隔：系统运行时从下位机数据采样轮询的时间间隔。即：每次轮询采集后，到下次轮询采集之间的间隔时间。

返回

4、运行系统中闪烁频率的慢速、中速、快速各是什么意思，如何设置？

在菜单: 系统--系统配置--运行系统配置的“系统配置”对话框中，设置慢速、中速、快速对应的闪烁频率，闪烁频率的值表示图素显示和隐藏的时间。

示例：快速闪烁频率设置为1000毫秒，则：在图素具有闪烁动画连接时，如果选择快速闪烁频率，则系统运行时，当图素闪烁的条件满足后，图素会显示1秒钟，再隐藏1秒钟，再显示1秒钟......达到闪烁的效果。

返回

5、如何禁止任务栏切换？

(1) 在菜单: 系统 -- 系统配置 -- 运行系统配置 的对话框中设置“运行时保持最大化”和“禁止任务切换”，运行时就会“禁止任务栏切换”。

(2) 用函数：SystemEnableKey()，通过参数设置 “禁止” 或 “允许” 任务切换。

返回

6、如何避免运行系统启动后，用户随便退出运行系统？

在菜单: 系统 -- 系统配置 -- 运行系统配置 的对话框中设置“运行时保持最大化”和“禁止任务切换”，运行时就会“禁止任务栏切换”。这样用户就不会随便退出运行系统。

返回

7、如何在运行系统启动时，显示指定画面？

在菜单: 系统 -- 系统配置 -- 运行系统配置 的“初始窗口”对话框中选择画面，在运行系统启动时，就会显示选中的初始画面。

返回

8、运行系统配置的定制菜单做什么用？

在菜单: 系统 -- 系统配置 -- 运行系统配置 的“定制菜单”对话框中，可以设置系统运行时显示的菜单，其中的菜单项可以根据设置显示或隐藏。

返回

9、运行系统配置中的通讯失败数据显示如何设置，各代表什么意思？

在菜单: 系统 -- 系统配置 -- 运行系统配置 的“其它参数”对话框中，可以设置“设备通信失败时数据显示方式”，共有四种显示方式：显示问号、显示0、保持原值、恢复到原始值。

返回

10、如何运行用户工程项目？

(1) 在开发系统的工程项目管理器中将用户工程项目设置为当前工程项目，点击“运行系统”。

(2) 在世纪星系统目录中，执行 ProjectSelect.exe 文件，选择用户工程项目，再点击“运行系统”。

返回

11、世纪星能否在运行状态下切换到另一个工程？

不能。

返回

12、如何在打开机器时自动进入运行环境？

将CSViewer快捷方式拷贝到系统：开始\程序\启动中即可。

返回

13、如何设置开机时自动启动世纪星组态软件？

(1) 选择“开始”按钮，打开附件，找到启动文件夹。找到后右击启动文件夹，选择打开命令。

(2) 点击打开后，系统会将启动文件夹打开。

(3) 将世纪星运行系统的快捷方式复制或拖到刚刚打开的启动文件夹下面。

(4) 开机时，世纪星运行系统就会自动启动。

返回

14、如何修改电脑的时间？

用函数：SystemSetDateTime()。

返回

15、如何多屏显示？如何快速定位画面到各个屏幕中？

(1) 多屏显示：在菜单“系统配置”--“运行系统配置”--“其它参数”中，选中“多屏显示”，根据使用屏幕数量，设置几个屏幕即可。

(2) 多屏显示是通过修改画面左上角左边，即：画面的X和Y坐标，将画面移动到相应的屏幕上。

(3) 想要快速定位画面，可以在菜单“查看”中选择“导航器”，移动要定位的画面，就可以看到画面在导航器中移动，直到画面移动到对应的屏幕中。

注释：多屏显示时，在菜单“系统配置”--“运行系统配置”--“特殊功能”中，去掉“运行时保持最大化”按钮，否则，只有一个屏幕有显示。有些用户为了在多个屏幕上显示画面，将所有画面的类型改成“弹出式”，这是非常错误的，会引起电脑越来越慢，甚至死机。多屏显示跟单屏显示时，画面的类型是一样的，只是左上角坐标不同，应该尽量多用“替换式”画面。

返回

16、世纪星可以实现仿真功能，就是可以当作仿真软件来用？

(1) 系统提供“模拟仿真器”工具，用于模拟外部设备与组态软件通信。

(2) 模拟仿真器具有多种仿真功能，如：状态变化、递增、递减、三角函数等，同时还支持仿真脚本，并且提供各种数据类型的中间寄存器，这样就可以通过脚本语言实现现场的工艺逻辑，达到设备仿真的目的。

仿真功能可以用于演示系统、工艺教学等方面。

返回

17、开发时，文本在矩形后面，运行时，文本却在矩形前面，为什么？

系统为了提高显示的效率，将不带动画连接的图形预先处理，带动画连接的则实时处理，如果文本带有动画连接，运行时就会在显示在矩形的上面，可以采用以下方法处理：

将矩形做“可见/隐藏”动画连接，连接的表达式为1，这样，运行时因为矩形也带有动画连接而后处理，由于矩形是一直可见的，矩形就会显示在文本的上面。